Cubase 9.5.10 does not start after Windows 10 update

Hello there,

I’m in big trouble here. Could you please help?

After installing yesterday’s Windows 10 feature updates, Cubase 9.5.10 has stopped loading.

It loads the loading screen but stops at Initializing: eLC. See>

After reading through many similar threads, because I know people have had SIMILAR things happening but NOT THE SAME, I tried different things:

  1. Reinstalled eLicenser Control Center many times. Always run with Administrator mode. Nothing changed

  2. Uninstalled eLicenser and downloaded an older version. Run it again in Administrator mode. Still the same bug.

  3. Deinstalled eLicenser and all older Cubase versions, downloaded the full 11GB Cubase 9.5 installer and run it. Still the same bug.

Now I don’t really know what to do next as the Support Chat function seems to be not working (though we are within the right hours now).

I have ad a look at yesterdays Windows updates and this is what I see>

  1. I tried using other USB slots for the dongle. Still the same bug.

Me too. Windows 10, everything seemed to work right after Fall Creators update. But today I am locked out Cubase Elements 9.5, Halion 6, and Halion Sonic. More licensing error messages than I can count. My USB eLicenser is not recognized for Halion 6 & Sonic. Same for my soft license for 9.5 Elements, it’s a no-go. Did all the stuff eriksumo described above, and then some. Spent quite some time on the support page. This is not my first licensing debacle. Not happy, but I’m beginning to like Reaper a lot.

Hello there Bill_T and others,

After a really long night, I took a deep breath and went on with reinstalling my whole system. The long and of nasty way, like creating a recovery drive on a USB drive and then go with a clean format, downloading reinstalling everything, the whole nine yards. This is the only thing that helped, now it works but I’m still missing some plugins.