Cubase 9.5.21 interface becomes a mushy blur

I currently use Cubase Pro 9.5.21 on Windows 10 Pro v. 1709.

After loading a project saved with 9.0, the interface suddenly changed color and graphics turned to a mushy blur.

As it is impossible to properly convey this problem, I made a short screencapture of it.

Link is to a YouTube playlist with two videos.
Video 1 shows the problem.
Video 2 shows the problem is gone after I reverted to a back-up of my user proflie.

I’m not positive the problem was caused by loading a project created with en earlier version, but this was what I was doing when it happened.
I’ve had this problem once before, but I don’t remember if it also ocurred in relation to loading a project last saved with a previous version.

I see that there’s an update to 9.5.30 available, but I don’t see my particular issue adressed in the version history.

Hi,

Try to install Cubase 9.5.30. Before you start it for the first time, trash Cubase preferences, please.

Yes - I’ll ofcourse install the update, but the issue isn’t adressed.

Why should I discard my preferences without reason?
Then what is the idea with the profile manager? - which, by the way, is a very appreciated feature when doing a major upgrade.

Well you do have a reason. They suggest that here with what feels like every problem. It often helps. See here for more info
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Interesting link - I didn’t know about that feature.

But anyway, no, I don’t have a reason - the problem I descripe isn’t related to updates themselfes.

Hi,

Trashing of Cubase preferences helps in several cases when Cubase seems to be messed up. I would at least give it a try.

I’d you have a stable Profile, of course you can use it (now or after the Preferences trash).

Your suggestion is exactly what I descibe as the solution to the problem - that is, a corrupt Preferences is the cause and reverting/resetting Preferences fixes the issue.

Anyway, thanks for replying to my post.