Cubase 9.5 with Icon 5x keyboard connection problems

Hi just bought a Icon 5x keyboard and its OK, However when i connect up i get a midi note activated when i press start or stop or any of the controls
Are there any Icon users out there who can help?

have you selected the Cubase preset in the Icon software?!

Hi Steve,
yes I selected Cubase and it shows on the icon keyboard
I then connect both port 1 and port 2
But I think that you can only select 1?
Then I select studio setup Mackie control port 2 for both input and out put
And then to Midi port set up

Ive tried so many different settings and what ever I do I always get sounds when i press the start or stop

Any help would be great!


It’ll be easier to help you if post images of all these settings. Be sure to include the entire window of each.

Hi Steve, yes! I was just thinking that! I will make it tomorrow


Hi Steve
So I am in Cubase mode
Midi port is set up
Mackie control port 2

So today the keyboard is working to play music but the transport controls do not work
When i first got the keyboard i tried to upgrade the firmware but nothing happened

One question is it posible to do a video meeting so that i can show you all the things that I have tried?

Thanks again for you help

Ive spent time this morning trying to get the 5x working correctly
The I map software is 1.11 and the firmware is 1.11 so OK
The I map visual on screen is not the same as the documents that i got with the keyboard
Using a program “midi monitor” I can see that the keyboard side is channel 1 (correct) and works
The controller (left side) is also on channel 1 and according to what I understand it should be channel 2
And that is why when I push the play button I get the sound of the current loaded keyboard side
Some times when i press the pitch bend it sends various messages to the Mac
and lots of different things go crazy
Is this a midi thru issue?
Must the controller be on channel 2?
I am o0n cubase 9.5 and the midi control is mackie contol Ive tried both chanells 1and 2 and it still does not work
Screen Shot 2023-02-19 at 11.52.37
Midi port set up is as per the screen
any help would be great

Regards James

Uncheck the port that’s routed from the keyboard to the Mackie Remote from
In "All MIDI Inputs"

Hi Steve, thanks for all of your help!
I did what you said i should do and…it still did not work!
On Sunday I wrote a long mail to ICONPROAUDIO and they replied today
They said i should download the actual Imap 1.11 (i had downloaded it at least 3 times previously) and then upgrade the firmware to 1.13 which they had posted only a few days ago
I did that and it sort of worked and then I did what you told me to do and …now it works!!!
The keyboard is port 1 and the controller is 2
The various other controls, slider and encoder do not really interest me at the moment but in the next few days i wíll give it a go
Thanks again!!!

Regards James