Cubase 9 Crashes on Exit

Just updated to Cubase 9. I’ve read before that other people have had trouble with Cubase crashing on exit – now it’s happening to me. I found a few threads but nothing that seems applicable to me (e.g. I have no fabfilter plugins so tweaking registry entries for them is a nonstarter). Any suggestions on where to start with this?

I have the latest win 10 running on a lenovo y50, everything is the latest and greatest (software, drivers, etc.) Plenty of horsepower. Only VST’s I have are Padshop Pro, Kontakt 5, and Zebra 2. The use case is as simple as 1) start cubase, 2) exit cubase.

Yes this crash keeps happening to me, i have to shut down/restart the Pc, because “end task” won’t even close it, it started great with no issue’s, took about 3 days for this to happen, then all hell broke loose.

Me too.

Event viewer;

Cubase9.exe
9.0.1.113
583db431
MSVCP120.dll_unloaded
12.0.21005.1
524f8413
c0000005
000000000003d023
25bc
01d2558041f28b0b
C:\STUDIO\Cubase 9\Cubase9.exe
MSVCP120.dll
5067327c-03cf-4575-8467-65ea24ba278f

MSVCP120.dll is part of the Visual C++ Redistributable Packages for Visual Studio 2013. I uninstalled this package, deleted both MSVCP120.dlls (x64 @ C:\Windows\SysWOW64, x86 @ C:\Windows\System32) and Cubase stopped crashing on exit. Reinstall the package and Cubase starts crashing again. Obviously this is not a perfect solution as MSVCP120.dll is required by lots of other software.

Please fix this.

Try quitting with the performance meter open an after it unloads the project.

Thanks, but still crashing for me at least.

Solved my issues. Turned out to be an ancient rewire.dll in my common files folder.

I found that quitting from the “file” coarse the crash, have no problems when closing cubase from top right X.

I’ve seen the same error in my log so I’ll give some of these steps a shot. FWIW, the behavior now seems to be intermittent. Would not be surprised if formatting and installing from scratch would solve my woes, not a viable troubleshooting step right now though.

Haven’t received any help from Steinberg, but I narrowed down the issue of crashing on exit. If I open a project using the Hub, Cubase will crash on exit every time. If I don’t use Hub (cancel or disable in preferences), it never crashes. I like the Recent files list in the Hub, but it makes my system unstable. Anyone else have same results?

I can’t confirm that on my end, unfortunately – hub use seems to have no impact on this.

I’ve taken a bunch of troubleshooting steps, but I can’t seem to tease out a pattern here. It just happens sometimes, and sometimes it doesn’t. It’s not a showstopper, so I’m not going to sweat it. It’s just very odd.

The Funny Thing is that this Problem has been around for some time now …
It has something to do with the MSVCP120.dll
Since Cubase 9 is fully 64 bit And doesn’t need the 32 bit version of the file
I just renamed that version of the file (Witch is located in the Windows\system32 Folder)
And … Cubase 9 did not crash when I closed it …

I hope with this information Steinberg could find a solution to this problem
Not that it’s that big of a deal but it is quite irritating and if clients would see it they might go to people who use other software

Now the Downside of the whole story …
Unfortunately some Company’s seem to use this 32 bit file for there 64 bit Plugin :open_mouth:
with some software I Could get away with Placing a Copy Of the 32 Bit MSVCP120.dll File in the same folder as the .exe file of the application (Works For NI Hardware Service)but I am nut sure if its a good idea to place this file in my VST Folder :confused:

Edit: Tried it … Doesn’t work for those Plugins … However Cubase does blacklist the file (Witch is a good thing in this case)

Can I just uninstall all the visual c++ stuff? I think elicenser and Massive need it don’t they?

I Would not Recommend it
Its only the MSVCP120.dll file in the system32 folder that seems to cause the problem
And without it … Massive will unfortunately not work (And also some other NI Plugins)
Not sure why this is since I still have the 64 bit version in the wow64 folder

btw it’s pars of the VC 2013 Redistributable Packages

I have Found A Little Workaround that seems to work
if the problem is related to MSVCP120.dll on A 64 bit system (Look in Windows Event Log to check)
Than if you set the compatibility of Cubase 9 to Windows 8 it should not crash on this issue
this is at least what worked for me
To do this go to go to the Properties of Cubase 9 (on desktop or the cubase9.exe)
Then go to Compatibility and set this to run as windows 8

Unfortunately windows 8 compatibility doesn’t work for me. I’ve tried moving the msvcp120.dll to various locations to no avail… anywhere my VST’s can actually see it, so can Cubase. So either $600 worth of DAW crashes, or $600 worth of VST’s doesn’t run. I will probably install another DAW until this is fixed. Unless someone here knows of a way to block Cubase and only Cubase from accessing this file and only this file.

FWIW I recently wiped my HD and reinstalled everything from scratch, no problems now.

So then I installed Ableton Live 9 and the crashes started happening again. I uninstalled, and they went away. How about that… I wonder if there’s something wonky in the way Ableton registers itself for ReWire that throws Cubase for a loop?

The rewire.dll located in Program Files/Common files/ Propellerhead/Rewire causes cubase to crash on exit.

The workaround is to delete the rewire.dll (or zip or move it somwhere else to keep it safe), however if you need Rewire with ableton or reaper its not a solution.


Here is the thread : https://www.steinberg.net/forums/viewtopic.php?f=250&t=109526&p=604607&hilit=crash+on+exit#p604607

I finally solved the crash on exit problem that I got after I installed Cubase 9. So far my workaround was to enable the Windows 8 compatibility option. But with this option enabled some plugins used to open very slow, e.g. iZotope Neutron.

Here’s my new solution:

Delete or rename the msvcp120.dll from the system32.
Cubase 9 ist still working properly afterwards and the crash on exit issue ist gone.

The msvcp120.dll will be installed by Visual C++ Redistributable Packages for Visual Studio 2013 and is used by Native Instruments as well as other applications such as the Acrobat Reader.

So my advice is to update, deinstall or reinstall those programs and plugins that won’t work anymore after deleting the msvcp120.dll and if they don’t work anymore without an msvcp120.dll reinstall the Visual C++ Redistributable Package Visual Studio 2013.

Good luck!

I’ve fixed my problem of exit crash by renaming the System 32 version of MSVCP120.dll. Thanks for the workaround!