Cubase 9 Crashes on Exit

Good to know - I have searched my C drive and see THREE (3) instances of ReWire.dll.

C\Windows\SysWOW64
C\Program files\Common Files\Propellorhead…
C\Windows\System32

Honestly not even sure WHY I have this on this relatively new puter. Which should I try removing? (should I remove from ‘common files’ one?

Just for grins - I removed the rewire.dll from the common files folder and STILL get crash on exit. Disappointing

That sucks. Have you tried removing all three instances of the file? That’s what I did.

bummer - removed all three copies of rewire.dll and the crash on exit still occurs.??? :frowning:

I want to pick up SB’s Dorico but NOW not so sure (will it be buggy?) 8.5 is super solid - just can’t get 9.x to not crash on exit???

Also here the crash on exit issue was solved by removing rewire.dll from Ableton.

Hello everyone,

Had the same problem and went through all the steps I’ve seen people trying:

Turned off the hub - didn’t work
Tried to exit using every possible exit, alt+F4, Ctrl+Q, Red X, etc - didn’t work
Running it in windows 8 - didn’t work

When I renamed the file MSVCP120.dll it seemed to work, at least it never crashed after that, problem was, Ableton Live stopped working after that. So, went back and renamed to the original name and tried to rename rewire.dll, so far after using cubase around 15 times it never crashed. Not sure if it was just this last change or the mixture of all of these, hub is still turned off, still running it in windows 8 and exiting alt+F4 most of the times.

There’s only one thing that bugs me, Cubase 9 not working, it’s not good but I know that sooner or later Steinberg will work on it, what bothers me is the lack of answer, I’ve requested their help and it’s been 6 days without answer, I’m sure they have a lot on their hands but come on… And it is the second time I’m left waiting for weeks, until I get an answer from them and I don’t even remember anymore what the problem was… The two times I had to contact Ableton for support I was given an answer after less than an hour.

Anyway, I’m a sucker for Cubase, so I really hope they fix this.

All the best to you all,
João

Have been dealing with this on Cubase 5 for a long time now, have tried so many things to fix it, but now just put up with it.
Had a strange issue with my browser not loading web pages (for no obvious reason) so did a 'Clean Boot (Windows 10) to correct this. https://support.microsoft.com/en-ph/help/929135/how-to-perform-a-clean-boot-in-windows
I don’t know how long this will last, but Cubase now exits as it’s supposed to.
Hope this works for you.

Where is Steinberg on this issue? The workarounds are appreciated, but totally unacceptable. Has anyone received a official response from Steinberg as a solution?

:frowning:

Same problem here, whether quitting from the menu or using the X in upper right of window. It happens even if no project has been opened. This is a fresh installation of Cubase 9 on a new Windows 10 computer. When quitting Cubase I get a box saying “Cubase 9 has stopped working” and giving me the option to stop the program. I’ll try some of the workarounds suggested here. It’s just an annoyance since the program seems to work fine until I exit it.

I did a search for “rewire.dll” and changed file name of all 3 occurrences. Cubase now closes without problem, but of course, rewire won’t be available. This doesn’t really matter to me as I don’t use it.

I don’t think any one of these “fixes” expose the true cause, a memory leak of some kind. This crashing behavior upon exiting has been around for 15+ years using every version of Windows from 2000/XP to 7/8/10 to Server 08/12/16, 32 or 64 bit, even the sister app Nuendo. Everyone who has this issue has varying results while trying any of the above mentioned remedies. There’s no one fix that works for everyone, which means that none of them are the actual root cause.

Users either deal with it, or move on to another daw. I’ve chosen to deal with it. Sucks, but those of us who have been around for a decade or longer have had to work around this flaw. :frowning:

Hi !
I did some testing i was having the same problem Cubase 9.0.3 crashing on exit and on closing so
my finding was i have a video in every sessions and when i disabled the thumbnails on the
video track the crashing stop so if you have a video check that out

JFR

Hi,
Same issue here on Cubase Pro 9.5 and Windows 10. I renamed all instances of rewire.dll and it solved the problem. I don’t use Rewire but - obviously - I now get a message upon opening Live that says “An error has occurred while opening the Rewire system…” after which Live opens OK though… To me this is less annoying than having Cubase crash on exit. Until a better solution is found anyway.
Cheers

Hi,
further to my previous… I disabled rewire in Live (and the annoying Live’s error message) by putting an “option.txt” file with the instruction -ReWireMasterOff in the \Users[username]\AppData\Roaming\Ableton\Live x.x.x\Preferences\

as explained in the link below.

https://help.ableton.com/hc/en-us/articles/209772865-Options-txt-file-for-Live

Hi,

I renamed all the “rewire.dll” files and now Cubase crashes NO MORE on exit! such a relieve … I do get that error when starting Ableton and I did the “option.txt” thing but it still appears … I can live with it as long as nothing is crashing!

Thank you all

I upgraded to Cubase 10 yesterday, and it doesn’t crash on exit :slight_smile: I’ve been in and out of the application 3 times so far, so we shall see. :slight_smile:

The Cubase ‘crashing on quit’ problem was driving me nuts. Everything I read in these forums and elsewhere said that you need to find the offending plugin(s) and go through the process of finding and removing it to fix the problem. Well, I wanted to be able to use any and all of the plugins I have and not have to take the time to eliminate each plugin to find the offending one, or or doing the quicker version of eliminating half of them to see what half the offending plugin is in, etc. etc.

So…

This is a fix for the problem of Cubase crashing/freezing on quit. This solution will allow you to keep using whatever plugin(s) you want even if they were the one(s) causing the problem.

First create a Cubase project that has one audio track with any old audio file imported and no plugins. Save it so that you can open it every time you start Cubase. Let’s call it the ‘dummy project’. Now follow these steps in this order every time you use Cubase.

1. Launch Cubase

2. Open the dummy project and keep it open

3. Open the project that makes Cubase crash on quit. (or any project)

4. Activate it

5. Work on it as long as you wish

6. When you want to quit Cubase, go to the window menu and choose your dummy project

7. Activate that dummy project (This will deactivate the project you were working on)

8. Close the problem project.

9. Close the “dummy” project

10. You may now safely quit Cubase

So, in essence, the one thing you never want to do is close the problem project while it is the active project. It may seem like a lot to do but it’s really only a matter of 5-10 seconds extra to resolve the ‘Cubase crash on quit problem’. I have a project that would crash Cubase 100% of the time when I quit. Using the method above I have now worked on that project for a over week (at least 7 times) with no crash problems at all.

There may be other ways of doing this or some of these steps might be able to be eliminated. But this has worked for me every time so far so I feel “If it ain’t broke, don’t fix it!”

I am using Cubase 9.5.41 on Windows Home 10.

Let me know if this works for you or if you have any questions. Also let me know if you’ve found other ways to fix the problem or have eliminated any of the steps above and still had success.

Macster

I am getting the crash on exit Cubase 10 too. And it is not all the time, it is casual. And I can’t delete rewire, because of using Reason. Btw. weird issue also with starting Reason. EVERY first time I boot PC to windows, Reason crashes always only on first start, but after first crash it runs properly then and I can run it and close it as I want to. Crazy :frowning: