Cubase 9 Not Outputting and not Inputting Audio


I’ve been using Cubase Elements 9 for about a year now with no issues. I’m using a Blue Yeti as my microphone, an Alesis V mini as a small midi keyboard, and the Siberia V2 headphones, all plugged in via USB. I recently decided I want to upgrade to better headphones, and I did, and I also bought an FX-Audio X6 DAC-Amp - also plugged in through USB. But now after switching to the FX-Audio device, I can’t get cubase to output or input anything. All I did was change the output device to the correct one (which showed up correctly) and Cubase stopped outputting and inputting sound - even though the input worked before. I didn’t change my ASIO driver or anything of sorts.

This is how I have it currently set up in Cubase:

Everything looks fine, but the audio just isn’t working. I’ve tried jumping to different projects, closing and opening Cubase, even rebooting my PC - and nothing helped. Obviously sound works all around the OS, listening to music and recording with no issues outside of Cubase.

All the discussions I can find online suggest to set up the VST system correctly, but as far as I can tell mine is OK. So what’s going on here?