Cubase and Cubase Studio 5.5.2 released

Hi all,

The updates to Cubase 5.5.2 and Cubase Studio 5.5.2 are available on the corresponding download pages!

Get Cubase 5.5.2…
Get Cubase Studio 5.5.2…

For further information on changes in Cubase/Cubase Studio 5.5.2 please refer to the Version History.

I just upgraded from Cub 4 to 5. installed all , updated my elicenser software, etc.

patched up to 5.5.1…

however, when i run the 5.5.2 exe file it says loading then just stops… not sure what the issue is

please help!



is anyone going to help me??

I assume your download is corrupt.
Did you compare the file size of your download with the original size stated in the links above?

Hi guys,

Trying to update to Cubase Studio 5.5.2 · 32/64-Bit (XP version)

Current version is V5.0.0 build 82 built on Dec 12th 2008.

About a second into launching the update I get Crc mismatched.

crc = cyclic redundency check either it got messed up during the download or it is a bad file.

Trying to download again, if that does not work, is there another source I can download from?

Thanks, appreciate your help in advance!


i’ve tried downloading from the links, from the FTP archive, multiple times for both.

still not working

i’m on windows xp sp3 32 bit

i’m kind of shocked with the lack of response from Steinberg staff.

last time when I was first upgrading from Cubase SX3 to Cubase 4 i had really great support/response from Steinberg staff who really helped me through the whole process which was difficult due to the usb license format changes

I wish someone would help

Hello Dinobose,

please contact our support department to solve the problem. The contact details can be found here



Do we still have to apply this fix?

Since the latest Update 5.5.2 for Cubase 5 and Cubase Studio 5 the factory presets of Roomworks and Roomworks SE are not available any more. To solve the issue please rename the preset folders manually like described below.

Go to:
[System Drive] \ Program Files \ Steinberg \ Cubase (Studio) 5 \ VST3 Presets \ Steinberg Media Technologies
[System Drive] \ Program Files(x86) \ Steinberg \ Cubase (Studio) 5 \ VST3 Presets \ Steinberg Media Technologies

Rename the folder “Roomworks” to “RoomWorks” and “RoomWorks SE” to “Roomworks SE”

I’m also having an update problem. I’m currently running Studio 5.1 and want to update to 5.5.2.

when I run the installer, I get a small window with a progress bar for a second, then nothing. Nothing happens! I’ve tried re-downloading the installer but the same happens.

I’m on windows 7 64bit.

Many thanks for any help!

Nobody? :confused:

Try clearing your temp directories in Windows and start again…

since installing this update it worked once for sevral hours then i closed the song down to open another
and now it says cubase.exe is not a valid win 32 application , i cant open any songs at all , cubase wont even load now
im going out of my mind …

the worse thing is somebody stole my install discs from the studio so i cant reinstall …i have my serial key and elicencer dongle but no install discs …please help projects all come to a halt once again!!!

£500 program is now useless


Thanks but that didn’t work - the installer still just does nothing.

Very strange!

Does this mean this patch will address;
a) The ability to load in Cubase 5.0 projects ? and
b) work with VST plug ins ( effects and/or instruments) that worked in Cubase 5.0 OK ?

I’m on Cubase 5.5.0 , and I don’t see much point in going to Cubase 6.0.
So I would really like a stable and supported Cubase 5 please.

I recently purchased cubase 5 and when I went to install it I received an error message saying that It could not install Because my system had not been modified, whatever that means.

my elcc, cubase, and windows are all updated and the computer has plenty of power.

I don’t understand what is going on or what the programs thinks needs modification.

Any thoughts?


I upgraded to 5.5.2 and firstly all the MIDI volumes on my projects don’t play properly. Cubase just doesn’t send out the volume changes at all.

This update is useless!!!

Also, the track folding is way messed up. When you maximise a track then un maximise it, cubase selects the top track for some reason. Way messed up!!!

It’s been like that for a while.

Actually it can be quite unpredictable just which track will be selected via the arrow keys.

There were some other complaints about related things in v6 forum.

One good thing will be the way home/end will work, so maybe the problem is on the way to being corrected.

It just unbelievable… I was about to buy a new expensive computer but I really am gonna have to start looking at protools soon. Can you do all the natty timestretch stuff on protools though?

What version actually works of cubase? I keep hearing people singing it’s praise but what version do they use cos so far, only 5.1 seems to be any way stable or useable and even that has horrible windows redraw problems and tons of other bugs. It’s a blinking joke…