Cubase and NI S88 aftertouch

Hi - I recently purchased the NI S88 keyboard. One of the features of the keyboard is aftertouch which allows for the additional expression after pressing a key. (I think :wink: ). I had not actually realised it’s effect until I also, recently purchased the Emotional Violin from Best Service. What I have been able to conclude is that depending on how hard I strike a key, the keyboard is sending an additional midi signal that Emotional Violin appears not to be able to handle so it simply re-triggers the sample. (Note VSL, East West etc. do not show this behaviour.) It is intermittent,again, depending upon how I press the key. It may re-trigger immediately thus sounding two notes instead of one. I came to the conclusion that is was the keyboard by playing the instrument using KONTAKT’s native keyboard where the behaviour did not occur. Please note that is behaviour is not as a result of re-bowing.

Best Service feels that I can turn off aftertouch “in my DAW” which is Cubase Artist 10.5. I am very new to Cubase and not sure how to do that so I am reaching out to you for help and advice.




Open Preferences > MIDI > MIDI FIlter. Make sure After Touch filter is not enabled here.

You can also record the data to the MIDI Track and then you can see if AfterTouch data is there.

Or you can test the plug-in, just add a MIDI Part, MIDI Notes and draw the AfterTouch data manually, to very if it behaves as you expect.

Thank Martin. There appears to be multiple places where after touch is shown.

Preferences > MIDI
Preferences > MIDI > MIDI FIlter
Note Expression MIDI Set-up

Should they all be disabled?



You mean the Chase Events, right? I would keep it enabled. This has nothing to do with your issue.

Keep it disabled.

You mean not. in the preferences, but in the menu MIDI > Note Expression > Note Expression MIDI Set-up, right? I would keep it enabled. This has nothing to do with your issue.

Thank you Martin - Yes you were correct in clarifying my post. Unfortunately, the re-triggering still occurs.

I recorded a short three note part where the retriggering happened on two of the note. When I open the key editor I only see each of the three notes (lines). I had expected to see five.

I purchased the Emotional Cello which preceded the Emotional Violin and it does not exhibit the retriggering. I may have to live with it and work around the samples as they do not all retrigger.

I watched the Best Service walkthrough of the Violin and the presenter played the same sample and I heard a retrigger of the sample and replayed that section to confirm that he had not restruck the key.

I posted a comment but did not here back.


This sentence is interesting… Does it mean you record 3 notes, you can see 3 notes but you can hear 5 notes? Are you sure there are really 3 notes recorded? When you select the notes one by one (select the first one, use arrow right key, arrow right, etc.), are there only 3 selection? Or are some notes split and they sit exactly next to each other? Or are the notes overlapping? How many notes can you see in the List Editor?

If there are really only 3 notes recorded then I would guess the instrument is made like this. If you play a long note, it triggers another note. This is most often done on the solo instrument. It emulates the change of the bow direction on the real instrument. Isn’t it this case?

Yes - I played 3 notes but it sounded 5 because the retrigger occurred twice. (3 actual notes + 2 notes I did not expect). I will look closer at the editor to see if notes are ‘stuck’ together. Most folks that I have spoken with think that it is bow change. However, I recorded a short two note audio where the repeated note happens very briefly after playing the second note. I can’t imagine any violinist re-bowing after such a short phrase.

I have an audio file with two notes this time; D natural to G natural. The repeated G natural plays on it’s own. I did not re-key. Unfortunately it will not let me attached a .WAV file to a post.


You could share the WAV (or MP3) via Dropbox or similar service, and share the link here. Then you could attach even the source CPR (Cubase project), what could be interesting to be able to compare side by side.

Am I right you said this issue doesn’t appear, if you change a sound on the very same track?

I wonder if this is supposed to work this way. i.e., the aftertouch isn’t really retriggering the same sample but is emulating an ‘up bow’ after a ‘down bow’ using the aftertouch. It sounds like that might be the case if their video shows the same behavior. I would followup/bug them some more or read the manual carefully to see if this is the normal behavior.

They did get back to me and it is re-bowing. The problem is that is seems to be (in their words) ‘automatic’. Meaning; I can’t seem to control it. I am going to have to live with this and utilize a combination of articulations (which I am supposed to do anyway). I still love the sound.

Thanks to all who helped me. I appreciate the support.


Try following this to filter the aftertouch:

Input Transformer Window
Specifying Filter Conditions

In the Input Transformer window that pops up, go to the presets in upper left and select Controller Filtering > Filter Aftertouch
Then make sure to click the “On” icon on the Module 1 tab to engage the filter.
Credit to Greg Ondo for this: How to Use the Input Transformer in Cubase

See if that works for you.


You can filter any MIDI message out also in the Preferences > MIDI > MIDI Filter. Enable After Touch filter for the Recording here.