Cubase and VEP

Hello, I am fairly new to this and built myself a template. I have been able to work with what I got so far on Cubase 11. But I seemed to have hit a wall.

To rule out system specs - AMD 3900X and 128 GB of ram. and samples are on a 1TB SSD right now. my OS and cubase is running of an M2 SSD.

So I built this beautiful template as seen in Figure 1 with all my sections and have been able to compose for a bit with it. It has been working fine. I have instances of VEP for each section as shown in Figure 2 and I load an articulation per midi channel then use a batch rename of each output channel. And it has been working beautifully. I have the samples purged and I had all the instances decoupled since I learned that saving (especially cubase auto saving) would actually hang both VEP and Cubase for a bit of time). There however seems some weird instances, where I was renaming one of my mixers as per figure 3 and it crashed. Maybe cubase 11 is buggy. But it worked the second time find without issue.

The next thing is when I am adding another track or midi instrument, the program seems to crash. For example, I was adding a new vep instance where I was going to use the Kontakt Factory VSL Legacy Harp. And I had success in adding it with its own folder and named channel. It just crashed once in that process. I think tried to add some of the woodwinds from the VSL legacy, particular piccolo and english horn just to see how they will sound. It crashed when adding the midi tracks, or after adding them when I was naming them, or naming their mixers, or moving them to the appropriate folder. A reasonable conclusion was that maybe Cubase 11 was just not stable for me. So I decided to open my project under Cubase 10. It also crashed while doing the same thing. My ram usage is maxed out at 40% and CPU is only showing 20% when looking at Task Manager. Did I hit a limit with VEP Pro server or the number of tracks that Cubase can handle? It seems its not really unlimited. But then if my computer has the resources to handle it, why is Cubase struggling with the count?

Any insight would be appreciated, thanks in advance!

1605490740153.png
Figure 1.


Figure 2.

Figure 3.

Hi erodred,

not sure this can help.
On my system, Mac Pro 2013, 128GB of ram, OS 10.14.6 I use a template with about 2200 tracks, VEP7 with 10 instances and Cubase 10.5.20 at the moment.
Actually Cubase handles more tracks, including VEP returns, than other daws. In my VEP settings I left 16 midi port and 32 input per instance as default, but raised audio output to 288. As the manual suggest, it’s not always possibile (i.e. with ProTools I can’t do that).

One setting to be aware of is under “VST Plugin-Manager” --> “VST Instruments” tab, on the “Search” field write “Vienna Ensamble Pro”, select it, and on the “Plug-in” information on the bottom disable the setting “ASIO-Guard”.

Hope this helps somehow. :slight_smile:

It crashed when disabling ASIO-guard as well. It just will not stay open and be happy.

My template is significally smaller than yours, maybe 100+ tracks only. I have it on 7 VEP instances as well. My project was made in Cubase 11. WHen i open it under cubase 10, it seems to just open it in cubase 11 for me so it does not get me anywhere at all. Hopefully what you suggest works. I am just getting into this hobby and Cubase has so far really discouraged me now from it. I might have to look elsewhere.

It crashes even in safe mode. I reinstalled it and no go. I have uninstalled it.

Now looking at installing just 10.5 and seeing if my project will open with it.

Got tempted to look into Studio One. It was able to open the project midi from Cubase no problem. Possibly even Logic Pro if I decide to invest in a mac…