Cubase and X-Touch issue (Mackie Control)

HI there!
I use Cubase Pro 11.0.41 and the behringer X-Touch with firmware 1.21
I cannot control the faders of my Cubase mixing console with the X-Touch. It is configured in Cubase as Mackie Control device, and the X-Touch is configured in Mackie Control Mode. The X-Touch is connected via USB.
I know some people with the same issue, as well as some people, running the same configuration without any issues.
I didn’t have this problem since the beginning and I’m pretty sure that I have this issue since I updated the Firmware of my X-Touch to 1.21

I Think since this moment the X-Touch shows up as “X-Touch” in Studio Settings - Mackie-Control. before the firmware update it showed up as “X-Touch_INT”. Don’t know if this makes any differences. In the computers device manager it still shows up as “X-Touch_INT”.

so here’s my question: How can I gain controll again to my Mix Console with the X-Touch?

Thanks,
Markus

Hi and welcome to the forum,

Does it help, if you set the MIDI Input of the Mackie Control to Not Connected and then you select the proper MIDI Input again in the Studio Setup?

Was this solved?

I have the same problem in C12, X-touch INT isn’t available for the output, so it doesn’t work.

It is available in Live 11 and Reaper.