Cubase Artist 12.0.40 running Rosetta 2 on Mac M1?!

Hi,

I recently updated Cubase 12 Artist to 12.0.40 and I noticed during the splash loading screen that its using Rosetta 2 intel emulation. The previous version …0.30 didn’t say this.

I have also noticed extremely high CPU meter spikes where before they were at a constant low.
I fear this is a result of using Rosetta. Please help resolve this.

Thanks

If the 12.0.40 isn’t running on your system, go back to the version that you were using the most without issues. In my case, this is 12.0.10. I know it has a couple of bugs but it was running very good. I’m having my own issues with my computer and I think I’m going to do a fresh install of macos. I hate to do that because it is such a long process. But it really cleans things up the one time I did it on another computer. Good luck.

You can disable Rosetta mode by selecting Cubase 12 in the finder and unticking the “Open using Rosetta” checkbox. You don’t have to downgrade.

Hi garymusic,

I just reverted back to .20 which I had before (not .30 as stated) and it works normally now. To be honest I had no reason to upgrade in the first place.

Thank you for clarifying the problem, maybe when issues are addressed then I will install the update. I did recently upgrade my OSX - So maybe that was the culprit.

Thanks

Hi Romantique_Tp

I never knew that you could switch modes,

I will try this later, Thanks for the reply!

btw … this info is added in 0.40

1 Like

@Mark_Joseph You need to right click the icon in the apps folder (not desktop icon) and select Get Info and in there about halfway down is the rosetta tick box. Changing between Rosetta and M1 is not a Cubase thing, it is an Apple OS thing. It applies to lots of apps.

Remember rosetta might be unticked but it can still be in rosetta mode. Tick it, then open C12, then close C12 and untick again then open again, that will put you in native M1. Thats just something you have to do with C12 the first time.

For some odd reason it installs as rosetta without the rosetta tick.

Having said that all my installations have remained M1 after i did that so i would say you have never been in M1 mode and you have probably been in Rosetta all along. Lots pf ppl think they are in M1 native mode but aren’t because of the silly way C12 first installs.

The 12.0.40 splash shows if your apple silicon or not.

If you have mistakenly been in Rosetta all this time be prepared to see a lot of plugins not to show up because they are not native or not vst3. But also be prepared for a 20% performance increase!