Cubase, ASIO & Direct Sound Issue


I’m just wondering if Cubase by chance can play audio output through Direct Sound instead of using an ASIO driver?

If not, I have downloaded SteelSeries Sonar and wish to play through the Sonar Game option, but the low latency ASIO driver doesn’t see the Sonar game option. The driver does see Sonar Chat and Sonar Microphone only. Can someone help on why it can’t go through game (The Game option has the option to switch through Speakers & Headphones mode which changes the sound completely)?

The only reason why I’m asking this is because I don’t have Studio speakers… only headphones.


I currently also only use headphones w/o speakers. However, I still use a dedicated audio interface with its own ASIO driver.

I don’t know how your headphones are integrated into Windows but they should show up as a device in Windows. They would use WDM or WASAPI driver models. DirectSound is not used in professional DAWs anymore. It just wasn’t good enough.

You can try to download ASIO4ALL. This is probably the best universal ASIO driver. It acts as a wrapper from ASIO to WDM/WASAPI, ie. any device that is registered with Windows will be available in Cubase.

ASIO4ALL is definitely a good ASIO driver but it doesn’t seem to work in my condition. But with what you mentioned, Cubase needs to have an ASIO driver (which is fine, I’ll still use Cubase for some production songs).

But… is there a way I can connect SteelSeries Sonar Game to Cubase? It’ll help out a lot because of their speaker/headphone mode. If not, that’s fine. I’ll just work around it

I am not familiar with that software suite but I guess it is not designed to work with Cubase.

My favorite solution for Windows is ASIOLinkPro

It’s free, very stable, near zero latency on every machine I’ve ever tried it with.

It includes drivers and a patch bay making it possible to mix and match ASIO with WDM apps.

It’s a little confusing at first, but stick with it. It’s very powerful and quite good!

  1. Set up ASIO Link Pro to use your proper ASIO audio device.
  2. Put it in multi-client mode.
  3. Enable LOOPER loopback racks (This is what makes it possible to route any ASIO or WDM streams anywhere you like).

From there, the confusing part is understanding that the first/main instance of ASIO link Pro takes over your Audio Device. The channels correspond to whatever your device offers.
I.E. My Delta 1010 has 8 inputs, plus 2 SPDIF, plus 2 Monitor/Mixer.
So the first 12 inputs match up with my device. Anything ABOVE that I can use with the loopback to receive from other apps, pipe into the loopback, and thusly, send stuff to other apps, and so on.

I get 8 outputs, plus another 2 SPDIF outputs.
So those 10 correspond to the ASIO Link ouputs for the main instance. Again, anything above the first 10 outputs, I can use for ‘internal routing’.

In your ASIO apps, you’ll connect to new devices that ASIO Link Pro provides (rather than directly to the audio device).

Same for your WDM apps. Use the virtual devices provided by ASIO Link Pro, and that gets you routed into the patch bay so you can send it where you like!

Now, in the patch bays of the various ASIO Link instances, you can route stuff like a BOSS! Even over networks :wink:

Each time you open a new ASIO app, it gets a new instance. Connect any INPUTS in these secondary instances. Do your OUTPUTS from the main instance.

Once you get the hang of that, it starts to flow.

Thanks for the responses! I’ll probably work around it. What I’m thinking is that the ASIO driver is seeing Chat & Microphone as a music piece and not the other two options. If there is a way SteelSeries Sonar can work with Cubase, I’ll look every so often here (only for a while).

ASIO4ALL doesn’t seem to work in this condition either… but no worries!

Thanks for all the help! It’s much appreciated and hope the best of days to you!

If I understand correctly…here’s an example of me using ASIO Link Pro to send a Cubase Mix into a WDM based application.

I’ve elected to use LinkOut 19 and 20 in Cubase for the Main Mix (These audio device connections are supplied by installing ASIO Link Pro).

Then I connect the ASIO Driver Out MIX of the main asiolinktool.exe instance to the ASIOVADPRO MIX OUT.

Now from within a WDM application, I choose the corresponding ASIOVADPRO device. In this case I’ll go for the built in Voice Recorder app that comes with Windows 10 since it’s the only WDM recorder I have handy at the moment.

Done. I have routed a pair of outputs from my Cubase mixer into an instance of Voice Recorder.

Yes, it is also possible to route a WDM application’s output INTO Cubase.

Note, if that app you want to stream between Cubase can work with ASIO drivers instead of WDM, that’s even better. Instruct it to use ASIO Link Pro as the main audio device, then it’s ASIO all the way. You’d use the loopback rail instead of the VADPRO connections to get streams going anywhere you like.

I can use this utility to:
Route live mics and instruments into Cubase.
Route Dorico into Cubase.
Route a two way Bidule Instance with Cubase.
Route Skype or Zoom into Cubase.

All at the same time!

Make sends and special output mixes routing whatever elements of the Cubase Mix I like back out to these apps.

I.E, I could send a special mix out to Skype, something else to speakers, something else to headphones, and yet something else to Bidule. All at the same time…and pretty much controlled from the Cubase Mixing console.

Thanks! I could use that!

Ouch, I missed where you said you might not have a true ASIO audio device at hand?

If not, try ASIO4ALL again, but merely as a bridge to ASIO Link Pro.

Still no luck? Consider picking up in the least a basic ASIO audio device. It’ll be worth it if you do much in the Steinberg ecosystem.

I do have plenty ASIO drivers. My true question was how could I make Cubase have SteelSeries Sonar Game Output when it’s not showing it. I’m not lacking in ASIO drivers but I want the ASIO to see the Sonar Game Output and it doesn’t

ASIO4ALL sees the Sonar Game output but can’t play through it… Don’t know why.

I don’t have physical devices…

Found a solution. Not exactly what I wanted but it’ll do. Thanks all again for the help!

hey i’m having the same problem and the only person that made a thread about it seems to be you. how did you solve it? even if it’s a workaround i need something cause everything that i tried failed.