Cubase automatically deselects track

Hey everyone, when working with Cubase Artist 12 i sometimes run into a strange problem. After I click on a track it automatically deselects the track, making it impossible to work with the track. Anysolutions how to fix that?


Do you use any Remote Device by any chance, please?

My connected devices are a nectar impact and a korg nanokontroll 2 if that helps


Try to unplug both of them, just for the testing purposes, please.

Do you have “select events under cursor” in the prefs enabled?

1 Like

ok I started cubase today and it was just gone, I actually only unplugged the conmtrollers, so maybe that fixed it. I hope it wasn’t just the restarting cause that would be annoying. When the same problem occurs again, I’ll try it with your tipps. Thanks for the help

that happens to me in cubase 12 pro, wtf?

Are you asking for assistance or just want to vent your frustration?

what kind of question is that? looking for assistance of course

Well, it wasn’t apparent from your post.
Perhaps you could include a little bit more information about your problem and what you have tried so far to remedy the situation?
What version of Cubase are you using? What OS? Any MIDI devices connected? Are you using any MIDI Remote? Etc.

Hi, using cubase 12 pro, on Windows 11 pro, I’m using elgato Stream deck. When I create a track or bus track sometimes a random track deselect when I want to change volumen or insert plugins, duplicate track etc. So weird. When I disconnect devices the issue still happens

Thank you for the additional info.
The “sometimes” bit makes it hard to get to the bottom of the issue. Especially since one users setup can differ greatly from another.
To find the root cause, I would recommend doing some testing until you can come up with a reproducible set of actions.
The first thing I would look at are any devices that would use MIDI Remote, Generic Remote or such. Also any 3rd party software that could potentially interfere, such as mouse/keyboard handler, AutoHotKey, etc.