Cubase cannot work with a powered USB for eLicencer?

I just can’t believe this. In order to be able to launch C10.5, I need to plug my eLicencer USB direct in my mac…

I have a powered USB through which iLok, a non-powered Time Machine HDD, and a few other things work with no hassle, but a simple USB for which the only function is to check your licence will be picky enough to require the rare birds we have on newer computers : USB ports ??

Whether I try it on even powered ports (to charge) or simple ports, I’m prompted as if I had no licence.

That is the kind of stupid things that has prevented me after years to jump solid on Cubase.

Others have that issue ?

macOS 1-.15.7
Mac mini 2018 6-core Intel i7. 3.2 GHz, 32 GB
SSD 2TB

shouldn’t be a problem, is the power USB powered via USB, or does it have an AC adapter? How long is the cable?

It works well on my Win10 and with an older USB2.0 Hub
so it is not a general rule that applies

Same here. I have a hub dedicated to dongles that is tucked away to prevent damage.

Try a different hub?

Same here got all my dongles plugged into a single hub. One of the cheapest hubs I could find. Works fine. I’ve used hubs that wouldn’t even look at a dongle. Sometimes it’s pot luck.

Thank you all.

My hub is not a cheap one. Atolla USB 3.0 and yes, powered with AC. It has 10 ports, each of these independently powered, I only have 3 to 4 devices and maybe 1-2 cables permanently in the charging ports.

The thing is : the eLicencer worked there in the past. I haven’t used it (nor C10.5) for several months. But the eLicenser now works when in a port direct on the Mac, so…

I tried different ports of course, but no success.

Try changing the cable between the hub and computer.

I did have the same issue with 11.0.20 but 11.0.10 is working good. Try a StarTech hub. I have used even a cheap one from Amazon and had no troubles.