Cubase "Content License check" - why every time? why so slow?

My Cubase Pro 10.5 install takes 1min9s to launch.

33 seconds of this is “Content License Check. 65 items”.

On a fast PC, with 32Gb RAM, running off SSD.

Does this checking really have to be done, every launch, while I wait? Even if the content is not being used? Why is it so slow?

If nothing has changed, can’t Cubase do some caching, for a fast-boot?

Right now it launches slower than booting the entire Windows operating system and launching Photoshop.

I moved the licenses to a new, latest tech, USB elicenser. Content License check still takes 31secs for 65 items.


Yes, this is license check. If you don‘t use it at all, you can uninstall it to speed it up. Also the new short USB-eLincensers are much faster, so you can speed it up by buying one of this new USB-eLicenser and transfer the license to it.

Thank Martin. New dongle was a good idea. But it seems to have saved only 2 secs.

I do use the content in some projects. And I am happy to wait for license checking when I use it. But I don’t want to wait for license checking during every start-up.


As far as I can see, you have Windows 10 and macOS 10.15 systems. Is it the same on both?

Just any idea, if any Antivirus or Firewall could slow down the communication to the USB-eLicenser…? Are you on SSD drive?

I have all the content installed only on the Windows system. Yes it’s on SSD.

I’m using a Mac and I still get those messages when I initially open Cubase. Every time I have to do a “safe start” then it works correctly. Really getting tired of seeing this but at least there is a workaround.

FYI - I just downloaded elicenser 2265 (latest) and it seemed fix it… for now.

I have the same problem in Windows 10 (1903) using Cubase 10.5 and 11.0.
What are these license checks for?
Did not have this issue before, I don’t remember when it started to show up. Could it be after installing any 3rd party plugins? I would like to find the cause of this.

I have the latest eLC and a new USB dongle as well.

Uninstall what exactly? What are these licenses?

I only have 5 licenses on my USB-eLicenser and Cubase is one of them, I don’t have 58 (in my case) licenses to check.
36 extra seconds to check licenses seems like a bug to me. It’s not a deal breaker, but it’s annoying because it wasn’t like this previously (don’t know when it started though).


I mean to uninstall the VST Instruments, if you don’t use them (HALion Sonic SE, Groove Agent SE), same as the library, which is part of Cubase license. Even though you would have only 1 Cubase Pro license, the license-check comes in place multiple times when loading Cubase. At last I can see the dongle is blinking multiple times

Ok, so I have uninstalled HALion Sonic SE since I don’t use it, but it still says 58 licenses to check and the same amount of time to start Cubase.
What else can I do? What is a normal startup time for these checks btw?


I don’t know, if you use all the sample libraries, for example…

There is no common startup time. It’s highly dependent on your machine, Windows optimisation, USB-eLicenser generation, amount of content… For some users the complete Cubase booting is matter of few seconds.

I had this a year ago. What fixed it is deleting the contentmanager.xml in the cubase data folder (where all the preferences are stored). The first cubase boot might be a little slower but after that it should be flying. I just tried it again and even now the content scan went from 8s to 4s.
The xml gets rebuild/saved when you quit cubase, not when you open it.
Let me know if this helps for you too, then we might have a permanent solution.
I am guessing the xml can get corrupted and cause longer boot times. Here it was definitively faulty as it kept asking about missing content with strange names. Deleting fixed that immediately too.
Also, deleting the media.db file can help if content is not showing. That one need a while to rebuild in the background while cubase is open. For safety back the files up beforehand, I just drag them to the desktop.

Thanks. I deleted the contentmanager.xml but it’s the same. I also deleted all settings by using Ctrl+Shift+Alt while starting Cubase but that didn’t help neither.

Now, I deleted all the “big” XML-files and the .DB-file. THIS worked. Cubase starts in a couple of seconds now. :slight_smile:
I will now copy over one file at a time too see where the problem is. I’ll get back.

Unless you have some exotic settings which are much work to do again, I would leave it as it is now. No need to use the old xml’s unless there is something special in it like key commands etc

It was the “mediabay3.db” file that caused the issue!!

What exactly is stored within this file? I don’t want to lose anything I’ve setup in MediaBay (meta-data like tag-data).
I have a huge library of samples so I would not want to delete any tag’s/meta-data (built up during years of usage).

I am not from Steinberg but I would guess you would indeed lose all that, but easy to check
Hopefully Steinberg can advice, maybe post as a new question, how to refresh the media database if the file causes issues…


I’m afraid this is exactly the data stored in the mediabay3.db file. Please, read this article.

File corruption can happen at any time on any files for sure. I’ll just copy the MediaBay3.db file from an older backup from a time where I know this didn’t happen.

Also, I’ll take this as a reminder to re-configure my backup software to actually do daily incremental backups of the entire system drive, not only the project disks. :slight_smile:

There are great professional backup softwares like Veeam available, which I know is used also in some professional studios. I use the personal/free version which can also save backups to a SMB/CIFS file share on a local server/NAS.

If you do incremental backups don’t they delete older files for newer ones. What if you notice an issue like this after the back upsoftware already did their work? Or can you adjust to save a new version and keep the old?