Cubase - Controller set up

Hey all… I have an interesting problem that is probably due to my expecting too much but I thought I would see if anyone has had similar issues. Technically, the issue is probably with the hardware manufacturers and not Cubase but I’m wondering if any of you have any ideas.

Okay, the Yamaha N8 digital mixer is my interface – great pre’s, very usuable input EQ. I love that it is designed to control the transport in Cubase. However, due to my current space limitations, I can’t always get to the N8. Also, I really wanted a control surface… so I picked up a Behringer BCF2000. I also recently moved my 88 key digital piano I was using as a midi controller to another room – too big for my space – and picked up a M-Audio Axiom 25. The 25 has these awesome little transport controllers that (on occasion) work really well in Cubase.

Now, here’s my issue: Cubase has started crashing on open when it tries to load the Mackie Control (presumably for the BCF2000). I have to close Cubase in the task manager and re-open it. It comes up BUT it forgets that the N8 is my audio interface and I have to select it. Guess what? It then doesn’t recognize my inputs. Shut it down in task manager again. After a few tries of this, it will somehow, magically all work together…

Does anyone have any ideas about making this set up more stable and reliable? Am I trying to do to much with this equipment?



I’m not using Yamaha N8, and Windows at all. But, in this case, I recommend to update N8 driver. Is it up to date? Is there problem with Mackie Control Off? Btw: which protocol uses N8 to the DAW control? Isn’t it Mackie Control too? Isn’t there problem with two Mackie devices?


The n8 driver is up to date. I’m not sure which protocol the n8 uses. How would I check?

What didi you have to set in the Device Setup as Remote Control protocol for the Yamaha?

I didn’t. It automatically did all that in the install. I think the protocol is the Yamaha Extensions for Cubase software…

Does Cubase crashes, when you insert the Mackie Control protocol, without MIDI In and Out ports? Or just, when you set the MIDI ports?


It will “hang” and crash on start up while it says Mackie Control is loading. I believe that occurs before the midi ports are set up…

For anyone else having this same problem, I ran the BCF2000 through the Midi in/out on the N8 and it seems much more stable now. Kudos to a really helpful youtube video suggesting it worked better through midi than USB.