Cubase Detects New Audio Driver EVERY time it starts!

Hi folks,

does anyone else have this issue, where Cubase detects a new audio driver every time it starts? This happens whether Cubase hangs on exit, or not.

Any workaround to fix this?
Screenshot 2020-06-19 at 06.33.01.png


Does your Cubase quit properly? Isn’t there a silent crash while quit?

I rarely get crash on exit, so its not a lost preferences thing as far as I can tell. This has been a problem for me for years on and off, and I’ve seen others report the same issue. Would be nice if Cubase would just lock to your main interface, which is how every other audio software I have behaves.

I’ve once had this some years ago, I had solved it by reinstalling the audio driver (ur28m).
Disconnected the interface, uninstalled the driver, rebooted and installed the latest driver.


I think, this is a driver issue. I remember, there was exactly this issue with Steinberg UR driver in the past, so any driver can do provoke this.

I can’t speak to how a Mac reacts to this opening process, but FWIW, in Win10, I have disabled (in Device Manager) the sound devices that don’t pertain to my audio work (Realtec (MB audio - no speakers connected) and AMD HD Audio Device (video card audio - non-existent speakers on my monitors)). As a result, having then chosen my Mackie ASIO device driver for Cubase and WL (before closing), when I open either program - AND - THE MACKIE IS TURNED ON - either program opens with the Mackie ASIO device in place.

However, if I open Cubase or WL without turning the Mackie on, the opening page (like what you showed) of Cubase offers me the ‘Generic ASIO Device’ driver. There is no way I can change this selection here, although I can turn the Mackie on at this point and it will seemingly offer the new choice of the Mackie ASIO Driver (but it can’t be selected). I have to open Cubase and then open my sound device options and choose the Mackie ASIO driver. At this point, provided the Mackie is turned on, I’m all set.

This may not help but it might.

Thanks for all the suggestions folks. No change this end. I guess it’s something I’ll continue to live with. I wonder it it has something to do with Loopback virtual audio drivers. I rely on these for other work I do, so removing them isn’t an option. Ideally I was looking for a way to make Cubase remember which audio interface to use.

Looks like the same problem i had ongoing for year. Try this:

sudo mv /System/Library/Extensions/AppleGFXHDA.kext /System/Library/Extensions/AppleGFXHDA.kext.old

This command renames the hdmi audio and display port audio kext. The path could be different on your system.

The issue has to do with the hdmi and display port audio drivers.