Cubase does not have sound

My cubase does not have sound. When i check on Outputs under Audio Connections, it shows not connected under device port. I cant choose device to connect. Anyone know how to fix this?

Two inquiries…

  • What is your audio interface, and have you installed the associated driver for it ?
  • Could you make a screenshot of your Studio>Studio setup>Audo device pane ?

If there isn’t any driver installed, you should at least be able to select the default Generic Low latency ASIO driver one.

Yes I am using Asio and I already installed it.
I can’t find audo device pane, do you mean this page?

Go into Studio/Audio connections/Outputs. Make sure you have your adio outputs set in there. Make sure you have a stereo out and it’s pointed at outputs 1 and 2

Yep, I made a typo (the i of Audio went missing…).

Indeed, I see the Not connected on the Out category, but it also seems that your actual audio outputs are listed in the In one : something that I’m not able to explain, as I have no experience of ASIO4All usage : I have always used a dedicated audio interface with my DAW, until now. So, I’m afraid that I won’t be able to help much…

Could you please make a second screenshot of the VST Audio System pane, though ? Just in case…

Just to be clear, and to summarize previous posts, there are two(2) places (menu screens) that need to be configured properly: one for the device and one for the connections.

ASIO4All is just a wrapper that makes your non-ASIO device look like an ASIO device to Cubase

1 Like

Here’s a short, concise video on how to set up audio in Cubase:

Hi, this is the Vst Audio System.

there is no options for me to choose in the Device Port section other than No Connections. I don’t know how to make the choices to appear…

OK. Confirmation that there is something wrong in your ASIO4All installation : no outputs available and an output latency equal to 0.000, this with the actual outputs listed in the In I/O… If you really have nothing else available beside the integrated Realtek sound chip, I would :

  • Uninstall ASIO4All as obviously, something went wrong during the previous installation (Realtek chip not correctly detected ?)
  • Check in the system BIOS that the Realtek stuff is active and working.
  • Boot again the system and reinstall ASIO4All, carefully checking everything during each step.

But again, I have no experience of ASIO4All. Actually, the best advice I could give you is this one : for any serious work with Cubase (as I see that you have the Pro version…), you should purchase as soon as possible a decent audio interface (there are countless rather cheap ones with decent dedicated ASIO driver, these days, even for $150), which at least will keep you from this kind of issues…

1 Like

I realized, after i choose Generic Low Latency Asio Driver in the VST Audio System, now cubase has sound!

But on the other hand, under VST System Link, now it shows Not Connected in the ASIO Input column. So I cannot connect it with my midi keyboard although it has sounds.

Which MIDI keyboard, and does it has integrated sounds ? If so, you’ll need to plug it also as an audio device in to your computer, one way or another.

And FWIW, I have never needed the VST system Link to use mine… What I always needed, though, is to have all the inputs/outputs correctly set in the Studio setup>VST Audio system>Device window pane, and consequently available in the Audio connections>inputs and Outputs ones.

Yes i think is the ASIO problem. I solved it by using another Generic Low Latency Asio Driver, now it works!

Thank you guys for the help. I managed to solved the problem finally. For future reference, this problem is due to soundcard problem, reinstall ASIO doesn’t work for ne but somehow i get another choices of Generic Low Latency ASIO driver, so that works. And for the MIDI keyboard that can’t be connected, is because i need to go to Studio>studio setup>generic remote and click plus on the top left corner, and choose Mackie Hui. This is video is very helpful!

1 Like