Cubase Doesn't Connect Generic Remotes to Lemur Daemon Outputs Automatically

Greetings Cubase Community!

I am currently running a program called Composer Tools Pro from MIDI Kinetics on my iPad in Lemur. I have 3 generic remotes, one for recalling info of MIDI tracks on screen, one for instruments tracks and a final remote for my custom key commands, all with CTPro.

When I fire up the computers, the Lemur Daemon and all other programs open up and connect automatically, but when I open Cubase, it fails to automatically read and link the generic remotes to their appropriate inputs and outputs.

Can anyone help me with this issue? It must have something to do with Cubase because everything else fires up and connects perfectly at start up outside of Cubase. Only Cubase fails to connect the remotes to ports itself.This is not an issue for me at home, only in the studio where I work.

I am running Cubase 9.5 on a mid-2010 Mac Pro and macOS Sierra 10.12.

Thank you!

My setup works correctly. Only thing I need to do is ensure lemur is fired up on the iPad prior to starting Cubase. This causes Lemur daemon to create the virtual midi ports so Cubase can see them on startup. If you start lemur afterwards Cubase doesn’t know the midi ports come into existence and connect the generic remotes.

Try that and see if you get a consistent connection.

Don’t forget, if you’re using generic remotes, make sure to save and reload each remote, then quit and re-load Cubase and see if that helps. Also, as the previous poster said, make sure Lemur Daemon is loading on startup.

I’m experiencing this problem as well, and can’t find any help on the subject.Cubase see’s the DAEMON’s midi ports, but never connects the generic remotes. I have to manually connect them each time, as well as disable the DAEMON ports from the “All Midi In” so that I don’t hear instruments triggered when I touch the controls.

DAEMON does launch at startup, and I’ve tried opening Cubase with Lemur open on my iPad - same results.

I’m attaching screenshots of my setup and would love any help.


As I said in my previous post, make sure you save and re-load your Generic Remote (Lemur) templates, then quit Cubase and re start. If Cubase closes badly it won’t remember the generic remote stuff.

The Lemur Daemon sucks. I’ve used Lemur for years and I’ve constantly had this same issue. The Liine folks seem to think it’s fine, unfortunately.

*As for a workaround, if you’re on a Mac, create as many IAC Buses as you have Lemur ports and connect your iPad, Cubase, and MIDIkinetics to those instead. Then connect the Lemur Daemon to the corresponding IAC buses. This way if the Lemur Daemon doesn’t load or crashes or freezes, your ports everywhere else stay intact. All you need to do is reload the Lemur Daemon and nothing else.

So for example, create an IAC port and name it “Lemur In 0” and another IAC “Lemur Out 0”, etc, etc, as many as you need. It’s just a matter of figuring out which port connects to where.

Yes, I use LoobBe30 for this.

As I said in my previous post, make sure you save and re-load your Generic Remote (Lemur) templates, then quit Cubase and re start. If Cubase closes badly it won't remember the generic remote stuff.

I’m not sure what you mean by save and re-load…are you talking about exporting and importing the XML files in Cubase, or the Lemur template itself?

One further point of clarification, which probably will shed more light - Cubase WILL remember the generic remote settings as long as I don’t restart my system. But after any shut down or restart, I will have to re-connect them.

Yes, save and re load each xml, then quit and re start Cubase.

Yes, save and re load each xml, then quit and re start Cubase.

Thanks. I’ve tried this - as before, Cubase will remember the generic remote settings, even after I’ve closed Cubase and entered hiberation, until I reboot my computer, and than they are lost.

Perhaps it has something to do with the way I’ve setup (or not) the Lemur Daemon?

Just a minior nuisance in the grand scheme or things - I’ll probably just live with it.