Cubase doesn't delegate key commands to active plugin


  1. Open a plugin with an editor that supports undo (I.e. press Ctrl+Z to undo the last edit in the plugin). (I’m using Ample Guitar, which according to their manual supports that)
  2. Make an edit and Press Ctrl+Z

Cubase should delegate the command to the active plugin, and let it handle it.

The undo command is done inside Cubase, in this case undoing the last action means undoing loading the plugin. This is especially annoying when you made a lot of changes to a plugin you just loaded and you’re instinctively trying to undo while you’re actually removing the plugin with all of your changes.

Note that some of the key command in the plugin I used to test it worked (for example Ctrl+O to load a riff in the riffer)

Of course this bug doesn’t reproduce with Steinberg own plugins (Like halion sonic), and it does reproduce in a bunch of other plugins I tried, both VST2 and VST3.

I was wandering if there is a way to solve it this? Some setup I need to make perhaps? Or is it a bug?


If you cannot reproduce it with other plug-ins (like Steinberg built-in plug-ins), then the issue is most probably on the plug-in side, I would say.