Cubase doesn't recognize the effects?

I bought a Steinberg UR22-MKII yesterday,trying non-stop to get it working since then and I might have developed an unnecessary anger tantrum.
Cubase recognizes the sound card,but it does not apply the effects. I believe the cause is related to my PC’s settings,but couldn’t find anything on the net that could help. Whatever I did, didn’t help at all. Guitar sound comes even when the software isn’t on, and I believe that’s also a problem since the sound should’ve been coming only when the software is on. Is it about DAW? I couldn’t find anything about the DAW settings. Sorry,I’m new to these things.

From the top of my head so sorry if it’s not entirely clear. Make sure you enable the box for hardware direct monitoring… Step 2 and 3 in the Procedure.

I believe applying the fx is done using one of the tabs in the inspector. Hope it helps… not at my pc right now. And don’t forget to enable the monitor button for the track.

my Direct Monitoring setting is grayed out,what should i do then? Deleting ASIO would work?

Turn the mix knob on the interface fully to daw.

then the sound that came through guitar cuts off

You have to choose one or the other.

The mix knob lets you mix between hearing the inputs directly (at all times) and signal coming from computer or daw. If you want to hear the signal processed with effects you need to monitor through the daw. Don’t forget to turn on the monitor button for that track while tracking. Turn it off to hear what’s already recorded. Of course you need to set the buffer size quite low for monitor through the daw (with effects). Otherwise the delay between when you play and when you here the processed sound can be quite annoying.

tried to do as you said,it’s still the same or i did something wrong

And you set the mix knob to daw and turned on the monitor button for your track?

Did you tried it step by step, as described in the manual?

Which effects? there are many possibilities…

ok i solved it,ty all