Cubase east west opus help

Hi I need help with east west opus

Whenever I try to load up an instrument it would direct me to the resource locator menu. This happens on some instruments, not all of them.

whenever I click the cloud icon in the top right corner of the resource locator menu it would give me the green circle in the top right of opus and download the instrument/sample, when done, I click on the instrument to only prompt me back to the resource locator menu again causing me to pull my hair out.

The library in particular that is giving me issues to the EW hollywood brass opus

I’ve already uninstalled and reinstalled the library, no dice

I’ve already located the library to its designated location in the east west installer

I have the current updated version of opus

I have already contacted support - they told me to do a “force complete download”. Upon doing that and firing up opus I get the same error

Currently waiting for a reply.

This is an issue whenever I have opus open in Cubase, HOWEVER, when I do the exact same thing in FL studio I have NO problem loading up an instrument in the Brass opus library. I have came across the same resource locator issue on FL studio on some instruments and it would prompt me to download them. I do so and have no issues loading/playing an instrument.

I thought it was a DAW problem so I did the exact same thing in ableton and it gives me the same resource locator issue. Same thing with Pro tools. (not that I would score in pro tools but just wanted to check).
I think it might be a DAW problem.
Anything helps

I had this problem and reloading the full libraries solved it.
Hope it helps.

Tried it and it did not work
I really dont know why and how in FL studio it works fine but when I fire up opus in Cubase the samples cant load for one library is mind blowing to me.