Cubase elements 8 won't open anymore!

Something caused Cubase to stop opening. Whenever I try opening it, it shows the loading symbol on my mouse for a millisecond and then nothing happens. I can see the cubase.exe opening and immediately closing in my list of processes as well.
Before this started happening my computer went through this:
I installed Photoshop and Unity.
Photoshop gave me grief so I though it was my ram timings, because I upgraded my ram a while ago and the bios didn’t seem to adjust the new timings to accommodate.
That didn’t help so I switched to an older video card and went back to using a single monitor.

This is when I had an itch to make music and tried opening Cubase. After seeing it wouldn’t open I tried resetting my ram timings back to normal, putting the other video card back in, and even trashing preferences and reinstalling Cubase.

Do you think unity installed conflicting audio drivers or something that screwed it up? Is there a list of files I need to wipe in order to completely do a clean install of Cubase? There were many Steinberg related files still on my pc after uninstalling.

Sorry for the trouble, and any help is appreciated!

There are “Knowledge Base Articles” found on the the Steinberg main website that explain how to troubleshoot issues and how to totally remove Steinberg software. I would have linked to a few but you did not list your system specs.

So click on this Steinberg Support link and search.

https://helpcenter.steinberg.de/hc/en-us

Regards :sunglasses:

Ah sorry, these are my specs:

Win7 pro
Cubase LE AI Elements 8 64bit
GPU: gtx1060
CPU: intel i5-2500k
PSU: Corsair tx650
RAM: G.SKILL Sniper Series 32GB
MOBO: BIOSTAR TZ68A+

Thanks for the help, looking through the support link now =)

Do you happen to know of a guide to completely remove cubase in windows? All I could find in the help center was a Mac OS X uninstall guide.

Not much but a little info is found in the “Reistalling the Software” paragraph here…

https://helpcenter.steinberg.de/hc/en-us/articles/206618850-Troubleshooting-for-Cubase-Nuendo-and-Sequel-on-Windows

Also… try this before removing Cubase: Make sure that Cubase and the eLicenser control center programs are set to “Run as Administrator”.

Regards :sunglasses:

I did eventually figure it out, thanks again =)

Please share what you found. Thanks.

Regards. :sunglasses:

I uninstalled everything steinberg related then searched my drives for “steinberg” and deleted everything left over I could find, then reinstalled.