Cubase Elements 9.5 won't Uninstall in Windows 7 64bit

Cubase Elements 9.5 has corrupted my system making it stutter badly trying to play audio in You Tube - as such I want to remove Cubase Elements from my system but unfortunately it will not uninstall giving me the following error message I have provided in the attachment.

I should also note that I am unable to do a system restore either as the same error in the registry prevents it.

I am on Windows 7 Home 64 bit version.

Just want to get this nightmare removed from my system so I can get back to recording - which I can no longer do with this software on my system.

Hi and welcome,

By using Google, I found the answer here. I hope it will work to you.

I found the same post before I posted here - unfortunately it did not work for me.

During the install phase I see “Not Responding” intermittently flash on the title bar of the install window on the screen.

Until ultimately I get the Feature_Browser_Emulation error message.

I then click on ok and receive the following message:

Cubase LE AI Elements 9.5.30 Update installation failed.
Fatal error during installation.
Error Code: 1603

I think the problem is that Internet Explorer does not work / update on Windows 7 64-bit - ultimately meaning that Cubase 9.5 is not compatible with Windows 7 64-bit.

Would have been nice if it was written on the box as I would never have purchased the interface in the first place given it effectively ships witrh no usable software.

During the install phase I see “Not Responding” intermittently flash on the title bar of the install window on the screen.

Until ultimately I get the Feature_Browser_Emulation error message.

I then click on ok and receive the following message:

Cubase LE AI Elements 9.5.30 Update installation failed.
Fatal error during installation.
Error Code: 1603

I think the problem is that Internet Explorer does not work / update on Windows 7 64-bit - ultimately meaning that Cubase 9.5 is not compatible with Windows 7 64-bit.

Would have been nice if it was written on the box as I would never have purchased the interface in the first place given it effectively ships witrh no usable software.

Cubase 9.5 is perfectly compatible with Windows 7 x64.

I think you need some update from Windows. Please run Windows update.

I run CB 9.5.30 Pro on my old PC running Win 7 64 bit. Also… I have the 64 bit version of Internet Explorer installed on it too. Both softwares run fine.

As previously mentioned… make sure your Win 7 PC is completely up to date. Especially ensure you have Win 7 SP2 64 bit installed.

https://www.steinberg.net/en/products/cubase/resources.html

Regards. :sunglasses:

There is no such thing as Service Pack 2 for WIndows 7 64bit according to Microsoft.

My system is completely up to date according to Microsoft update and it makes no mention of any service pack beyind that being available.

Where did you get SP2 from ? or do you mean the SP1 Rollup Pack ?

What version of Internet Explorer are people running and do they also have Silverlight installed and if so what version ?

I am running Internet Explorer 11.09600.19002. If anyone is running something more recent than that could you please advise how given that Internet Explorer 11.09600.19002 is the most recent available from Microsoft Update - and has been for quite some time.

I’ll verify once I get back to the W7 PC but… you are probably right that it is SP1.

Regardless of the versions… my CB 9.5 runs well on the W7 pc.

Regards. :sunglasses:

Just following up…
My old PC lists the OS as Win 7 Professional SP1 (can’t find a version #)
I have both 32 & 64 bit IE programs that work on it. Both list 11.0.9600.18282 (one says 64 bit)

This computer has been offline for some time now so I’m sure the latest 32 & 64 bit IE downloads are more recent. They are available here:

https://support.microsoft.com/en-us/help/17621/internet-explorer-downloads

Good luck and I hope you can figure out why CB 9.5 is not working for you on your Win 7 PC.

Regards :sunglasses:

Thanks Prock.

I wonder if the problem for me here is that I actually am fully up to date with respect to Windows 7 64 bit.

Everyone I have found so far that is running Cubase 9.5 on Win 7 64 bit has an older version than I do - or they installed it on an older version of the browser.

That’s a good point about the older versions of the OS & Browser. I hope others using Win 7 will comment on their working CB 9.5 on Win 7 specs for you.

Regards :sunglasses:

I sent my error codes to Yamaha / Steinberg and they [Jarrod Bayliss] got back to me the next day.
While Windows update said I was completely up to date - the errors I was receiving were specific to. Net Frame Work.

So I checked the registry and sure enough - I had version 4.0 which is long out of date.

I installed .Net Framework 4.7.2 - and now Cubase installs and works perfectly.

Very happy. Thanks to everyone for their assistance.