Cubase Elements 9 blue screen of death working with midi

Hey guys. So for the past month or so I’ve had 3 blue screens of death, or it will just crash during playback with the program frozen but the audio still going. This started happening when I started using a microkorg midi with clock data synced. So the info to begin resolving this is probably out there somewhere but I’m not sure where to begin. I run my midi through a focusrite I/o.


The blue screens are mostly hardware (driver) related nowadays. Make sure you have the very latest microkorg driver installed, please. Maybe search on the org forum, if this issue is mentioned.

Thanks! So the keyboard has drivers? I’m obviously pretty new to this tech. Here is a link to the vocoder in question;

Any help in finding where this update would be available and how to go about updating it would be appreciated.

I’d really be surprised if the issue was with the vocoder drivers. I think it may have something to do with MIDI messages being sent between Cubase and the synthesizer… There’s a lot to take into account so it may be a trial and error situation. Just sucks that the issue would go straight to a program or even system crash.


There must be any kind of driver in any case. Might be, org is using the generic MIDI driver, I don’t know.

Make sure, there is no MIDI loop in your connection.

Thanks. Yesterday I noticed that cubase is using a lot of power in task manager as well. I updated my Scarlett firmware so I’ll have to see if that helps. Also noticed that the Scarlett firmware doesn’t register my interface as connected (but still works) unless I unplug it and plug it back in after booting up, and that the software has a power optimization feature, so that might help as well. Before updating my Scarlett firmware I got a nasty failed to start screen booting up my computer, and it said the reason was scarlettusbmidi. I’ll check in if I make progress.

Now I’m not getting any output through my headphones through my Scarlett interface. It’s sending input signal. I’m not getting output through my pc sounds through the Scarlett either. Going to have to step away for a bit…


If you set Focusrite as an ASIO driver in Cubase, you should hear the signal from Scarlett (if the routing is correct), but not from the built-in Audio Device.

Thanks for the response. I’m working through the situation as I get help like this. How would I go about making sure that setting is correct?

Booted up today a few days later and I now have output.

Yes it is set to focusrite.

After about 10 seconds of using cubase I’ve lost output again.

Maybe my Realtek drivers are interfering?

So like magic, I was able to use cubase for probably about 4 hours with no hiccups. My outdated focusrite drivers were likely the problem. We’ll see if it’s consistent.