Cubase Elements won't detect my audio interface?

Audio interface: Alesis IO2 Express
When I go to Devices>Device Setup>VST AUdio System and select my ASIO Driver io2 doesn’t show up.
The available options are “Generic Low Latency ASIO Driver” and “ASIO4ALL v2”

Somebody told me to download the ASIO4ALL driver and it still doesn’t work. Help?

Hi.

This was my first soundcard. I’ll never buy a soundcard which doesn’t have its own asio driver for this very reason.

Did you try to set the Alesis as Windows default audio device?
Although this is usually not recommended, it might help.

If you open the asio4all control panel, can you see it or select it there?

Another thing to try would be don’t select asio inVST audio system setup, but use the windows built in driver, whatever it’s called.

The available options are “Generic Low Latency ASIO Driver” and “ASIO4ALL v2”

This is as it should be…You need to select ASIO4all.

[quote=“misohoza” If you open the asio4all control panel, can you see it or select it there?

Another thing to try would be don’t select asio inVST audio system setup, but use the windows built in driver, whatever it’s called.[/quote]

I couldn’t locate the control panel? The other stuff didn’t work.

There is no option for ASIO4all, just ASIO4ALL v2, and it doesn’t work.

Hi.

I found the io2 and tried it.

Select the Generic Low Latency ASIO Driver. Click Control Panel.
When the control panel window appears, uncheck the first checkbox.
io2 should appear as option.

I believe it would work the same way with asio4all.

See the picture.
io2.png

There is no option for ASIO4all, just ASIO4ALL v2, and it doesn’t work.

Have you opened the ASIO4all control panel to see if the i02 is listed there??

Does the i02 work with windows sounds??

The io2 does not show up for the Generic Low Latency ASIO Driver: http://i.imgur.com/stZ891X.png?1
The io2 DOES show up for the ASIO4ALL v2 driver, however when I select it (shown in this picture selected) any of my normal audio does not work, and when I try to record in cubase it doesn’t work: http://i.imgur.com/1pyB292.png?2
The io2 is my computer’s default playback and recording device: http://i.imgur.com/SaRAHNX.png?1

Still can’t figure it out.

The io2 DOES show up for the ASIO4ALL v2 driver, however when I select it (shown in this picture selected) any of my normal audio does not work, and when I try to record in cubase it doesn’t work:

you just need to assign the ins and outs…sometimes this happens automatically but it seems not in this case.
You do this in VST connections.

Thank you, I have done this and my audio works. However, I have noticed one problem. I successfully recorded into cubase, and there are visible sound waves. However when I play it back I can’t hear anything. I think this is because in VST Connections>Outputs the io2 isn’t showing up when it is for Inputs.

http://i.imgur.com/99lmNjF.png?1

Yes. You need to configure output as well.

This problem randomely fixed itself, but I removed my audio interface and put it back in, and now it is not showing up as an output again.

You have to set the outputs in vst connections as already stated.

click on where it says not connected and it gives you the outputs to select.

Keep in mind that working this way is in principle the same as working with a builtin soundcard, which is not a best practise!
ASIO4ALL is a sort of software bridging your problem with other software.
In other words it tries to emulate a real asio soundcard.

ASIO4ALL works good in many cases as long (in my experience though) as you do not record audio but stay with playback only.
Also do not expect very low latency figures as this will only multiply the stress on your system.