cubase error application rev-x vst 3

Long term Cubase user here, but new to 9.5. Appologies if I’ve double posted this…

I have a problem with a brand new high spec PC and brand new Cubase 9.5 Pro & UR824 bought as a ‘recording pack’ and have been using it for about 2 weeks.

I have installed and registered the all software, including the Basic FX Suite and used the latest Yamaha Tools download package over the include CD.

After about a week of use I got the error - application rev-x vst 3 has caused the following error - a required licence has been disabled. Please verify your local date settings and start the elicence Control Center to validate.

Which I have done many many times.

For the past few days I’ve ‘managed’ to somehow get it going, by repeating that process. Which I’ve had to do every time I restart Cubase, until today.

Cubase hangs, so I have to ‘end process’, reboot and try again.

Now today, there is one very importent project I’m due to work on, but I can’t even open the project. I can open projects which do not have the Rev-X VST, but not the ones that do.

I opened a support ticket about 3 or 4 days ago, but i’m yet to get a response.

Please help! I’ve spent a lot on this audio specific PC AND the DAW Cubase & the UR824 and really need to work on this project.

My elicencer version is
I’m running 64 bit, Win 10


So, I managed to get it running by reinstalling the Basic VST pack.

Then after a reboot Cubase hangs again…same error

I think I have a workaround, which is this.

Open a Cubase project that does NOT have any of the Yamaha stuff used in it - Rev-X, Channel Strip, Amp etc.

Insert the Rev-X VST. Don’t save. Close project. Open the original project that has the Rev-X in and voila, all good until next reboot.

Not great customer support however.

I’m suddenly getting this error as well. Any progress or comments from Steinberg?

My problem:
Opened a project today (26/3/2018) that was last saved on the 25/3/2018 9:15pm. I get the Rev-X plugin elicenser error window, several things continue to load then Cubase 9.5.20 completely freezes and I have to End it in Task Manager.

Reverting to an early save (24/3/2018) works perfectly.
There is a lot of work between those two saves so I uninstalled the Basic FX Suite so Cubase couldn’t load it. Replace the Rev X reverb with another one and the new Rescued project is working.

Reinstalled BasicFX suite, went back to the failing project, still fails with same error.
I did elicenser maintenance as well, no change.

So then, because I am a sucker for punishment. I used the Rescued project, and added a shiny new Rev X FX Track to it. Saved (new version), quit Cubase, reloaded and viola it works as before.

So looks like it isn’t a Rev-X plugin issue per se, just a somewhat more concerning self corrupting Cubase project file!!

I tried every automatic back up I have of the corrupted project file as well, and those available from the 26/3 (about 7:15pm-9:15, 8 backups) all exhibit the same error.

If this is indeed a corrupting Cubase project file I do hope Steinberg are watching this!

I believe Steinberg resolved this with a recent eLCC update. Ver
The latest version is available on their site.

To test if this will solve your issue, you may try running the eLCC (and leave it running) before opening Cubase.

Hope this helps