Cubase graphic bug/problems

I have a strange issue. Fonts in parts of the Cubase interface that are not in use are gradualy degrading in quality when I click or use other part of the interface. When I click or hover with a mouse above certain icons or text, it becomes sharp again. If I resize project window, it redraws and everything is ok again - until I start clicking or I click on some other app, open web browser etc. Also, audio files look like they are empty, there is no waveform visible. If I change color of the part so that it is different, waveform becomes visible again and stays like that. It is invisible as long as its color is the default color of the track. Btw for some reason I can’t attach more than three photos, so I will link two from imgur.

I am using Cubase with 32" UHD monitor with intel HD4600 graphics integrated in 4790K CPU. Attached images are made with this configuration (scaling in win 10 125%) but I have also tried if there is any difference with older 1680x1050 monitor and no text resizing and issue stays the same. I don’t have this kind of a problem with any other software. Rest of the configuration is 16GB memory, system SSD, 3 HDs.No other issues on system for the last few years except this one. HiDpi is off in Cubase because…well because it is unusable, but it is another story.

Cubase start up screen shows the same problem:

Here, part of the opening screen that is drawn first (recent, recording etc) becomes “low res” when left side menu opens. Left side menu is visibly better looking. Same thing is visible here with other fonts:

Here is one of the tracks.

Fonts look wrong, waveform is not visible.

Here is how it looks when the project window opens:

But if I resize window it looks like this:
It is still not amazing but looks much better from viewing distance.

As soon I starts scrolling through project, everything falls apart again, both text and graphics.

Does anyone else have similar issue? I thought that this could be solved by getting new graphics card, but I really don’t need it, I don’t play games and integrated graphics were fine up until now for all other applications. Even if I solve it by cashing out for a better GPU, it is still an obvious bug. I have experimented with different settings in Intel hd4600 panel but nothing changes.

I also have some other bugs that were mentioned in posts on forum, like the one that makes it impossible to save/reload graphic preferences. Only some of the colors are recalled, but some are not, background color always defaults back to dark grey for instance.

Reset colors in preferences

I have already tried to open Cubase in safe mode and delete preferences, and also renamed folder manualy to let Cubase rebuild preferences, just in case. Although, redrawing of Cubase graphic interface probably doesn’t have much in common with colors in preferences.

I’d take a guess that your solution might be in the settings and/or driver of your graphics interface.

I’d check for updates for your graphics driver and then take a look at the settings.

I’m guessing the monitor is connected via DVI or HDMI not analog VGA? If it was an old VGA connection then that might introduce some video distortion.

Sounds an annoying issue, hope you get it sorted soon.

Thanks for your reply, but as I have already said, I have tried different monitors and connections, it does not make any difference, and it is only problem with Cubase. There is no general distortion, in other apps. Issue was also there with previous version of Intel HD drivers, I have updated them recently. Problem was there since I have installed Cubase, it’s just that I didn’t post here about it because I have noticed that there was already some graphic bugs that people were complaining about, and I was hoping that 0.30 update could solve this. But the problem is still there. Frankly not counting on Steinberg to help with this, even less on intel if it is the source of problem (they have a history of bugs in drivers as far as I know). I was just hoping that someone else using win10/hd4600/Cubase combination has had similar issue and hopefully solved it in some obvious way I have missed to see