Cubase group track latency results in poor syncronisation of rendered-in-place tracks

The main problem I’m currently struggling with is poor track syncronisation in a mixdown audio. All the sample rates and bit depths are the same for the mixdown, the project settings and the studio setup. I’ve been seeking for the solution for quite a while and this is what I’ve come to.

I know that if two audio tracks are exactly the same (including syncronisation in time), with phase inverted for one of the tracks both the tracks played together suppress each other and we do not hear anything.

I tried to render several guitar tracks which are routed to a group track. Then with phase inverted I played the initial group of tracks and the rendered track and tested if there is silence – and there wasn’t! I had to place the rendered track almost 22 miliseconds later to make the tracks fall silent.

I removed everything from the group track to exclude any influence of plugins, equalisation, etc. Then I duplicated one mono raw guitar signal track and routed one to the empty group track and the other directly to the output. When routed to the same output, with phase inverted the two tracks are silent. When routed to different outputs (one to the empty group track, the other directly to the output), inverted phase does not make the tracks silent without moving one of them. And in my case the difference between the starting points of the tracks must be the same ~22 ms.

When playing back in Cubase, everything feels OK, but when rendering or exporting, group tracks seem to cause some time shifting of the tracks which are routed to the group track.

The final problem is that I have poor syncronisation between tracks when exporting an audio mixdown. I tried realtime export, different formats or bit depths, switching options in studio setup (such as adjusting for record latency and others), no luck. So here is what I found. The only solution that may be is to render these group tracks and then move them 22 ms farther, but this is ugly. What is the reason for such behavior?

And You removed them completely, not just bypassed them ?
I guess it’s Cubase 11 (tag) Pro ?
Mac or PC ?
Audio device ? Internal sync?

To me it sounds most likely to be a plugin that is reporting the wrong latency.

Exactly, removed, because I’m not sure if bypassing unloads CPU.

Yes, as I tagged it

Win 10 x64

Boss Katana Air. I also tried Generic Low Latency ASIO, didn’t make any difference. No external sync.

Again, all plugins on the group track removed

There is one more thing I have found.
The distance to make the tracks silent with inverted phase seems to depend on the output latency. In the example above it is ~21.9 ms. When I increase the buffer size in the control paned so that, for example, the output latency is 33 ms, this distance to make the tracks silent is also at around 33 ms. This may be evidence that group tracks have the same latency as the output latency.

Does disabling ASIO Guard, do anything.
How about changing the audio engine to or from 32bitfloat to 64bit DP, any change ?
I’m a bit stumped, hopefully someone else has more ideas.

I already have 64bit DP, since 32bit initialy caused problems with sync of metronome and drums
Disabling ASIO Guard won’t help