Cubase Hung Up on Initializing

I bought the UR22 with the free AI7 download a couple of weeks ago. I installed the software and everything went fine. I also had some plug ins and Addictive Drums that were showing up in Cubase. I played around in Cubase awhile using Addictive Drums but didn’t install the UR22. Everything worked fine.
So, I hooked up the UR22 and the problem began. When I try to load Cubase, it gets hung up in initializing and never loads. I even waited hours and still it didn’t load. Tried at least 3 times. I would also have to shut the computer down cause there was no way to stop it.
I need help with this problem. What do I need to do to get this working? Thanks.

When you say “hooked up the UR22” did you also install the proper drivers or did you just plug it in? You will definitely want to install the manufacturer’s supplied drivers. Then, also make sure you have selected that driver in the Cubase device setup dialog.

I just plugged it up. I will try and install the drivers your talking about. Thanks for the reply!