Cubase is not copy & pasting automation points accurately

I’m trying to copy & paste some automation points. The first point starts at 0 & the next point at maximum, right above it. Then the third point is 1/16th from that, creating a triangular fade. The problem I’m having, is that when I try to copy & paste these points, Cubase is adding an extra point slightly above the third point, with a slightly higher value (0.44 or 0.52). This in turn creates the problem of what should be the third point not having a value of zero anymore. It’s really annoying because I can’t always see the extra point, it’s hidden behind the third point.

Why would Cubase be doing this??? And how can I prevent it from happening? It’s slowing my workflow right down & I’m getting frustrated because I can’t get on with my work! Why can’t Cubase just copy the highlighted automation verbatim, without adding random extra points where they shouldn’t be???

1 Like

I do not believe I have encountered this.
It would be helpful if you could share what version and level of Cubase you’re using and on what OS.

Have you tried this on a new, blank project (not from a template)? Have you tried it after starting Cubase in Safe Mode with Preferences disabled?

Are these the proper steps in order to recreate the issue?
  1. Start Cubase with a blank project
  2. Create a new Audio Track
  3. Open the Automation lane for Volume Fader and add 3 automation points with the following values: -inf, 0db, -inf
  4. Using the Range Tool, select the 3 automation points and copy them using Ctrl/Cmd + C
  5. Move the Project Cursor away from the selected range and paste the previously copied points using Ctrl/Cmd + V

I’m using Cubase to create light shows with DMXIS. The automation tracks control each DMX channel. I’ve created quite a few light shows so far, but today is the first time it has started happening. Every time I try to copy & paste a series of automation points I have drawn, Cubase is not snapping the pasted points accurately to the grid. It is only the very last automation point that is being affected. It is also creating random extra points in the same place, also not snapping to the grid (see image) with a higher value.

I’ve noticed that if I create a new blank project, the automation copies & pastes fine. When I then import a midi file I use to set the project tempo, that appears to be what causes the issue. Cubase will then glitch. Could it be a corrupt midi file? There’s no note info, just tempo definition.

Am I also right in thinking that copy & pasted automation should still snap to the grid, even with varying song tempo?

I have the latest version of C12.

Lately i have the same bug

I also believe that there is a bug when copy and paste audio events. It happens too.

@G-row12 Audio events? Then that is a different topic.

1 Like

It appears to be when tempo changes are introduced to the project. I’m assuming Cubase places the pasted automation points in a linear fashion & so if the grid lengthens or shortens because of tempo changes, it gets confused as to where to put them. I’ll raise a support ticket & let you know what they say.

Hi guys. Steinberg Support couldn’t recreate the problem, but I’ve found an easy workaround. Simply add another automation point one beat after the final automation point of the group of points you want to copy & paste, on each of the relevant automation tracks, with a value of zero. Then simply copy & paste as usual.

I’m not sure why, but Cubase seems to get confused when tempo changes are introduced to the project & doesn’t know where to place the very last automation point each time because the grid increases or decreases in size due to the tempo changes. So by placing an extra ‘last’ automation point, you eliminate this problem. Not ideal, but it works.