Cubase is not recording midi from my keyboard

Hi,

What about the other settings I mentioned, please?

Solved for me: I deleted my Cubase custom preferences file and started from the default settings and my midi keyboard was recognized. Must have been a corrupt setting after installing/testing a new version.

I have the same issue. Where do you find the custom preferences file? tx

I would say, check your USB device drivers if you are running windows 10. I had the same issues and just solved it yesterday. Here’s what I did
(1) Went to device manager, checked for any driver that’s flagged “unrecognized by windows”, there are other terms windows uses to show you specific issues with a driver…so be on the lookout for it.
(2) Right-click on that driver and click uninstall.
(3) Power off your computer and power it on again
Windows will reinstall that driver and you will be fine.

Unless you have issues with MIDI Filter, then you can go to Edit>Preferences>MIDI Filter> check to see the parameters filtered out. You only want “System Ex” ticked at the least. This will solve any Cubase-originating issues with your midi keyboard. Also ensure that in the Midi section, the “Midi Thru” box is ticked as well. If not ticked, your midi keyboard wont work.

Cheers
Hope this helps