Cubase is not recording midi from my keyboard

I had connected my keyboard to my computer, and it works fine in other programs (such as Audacity)
However, when I try to record midi from my keyboard in cubase, it doesn’t work at all.

The bottom right corner which shows the midi activity does respond when I use my keyboard, but it just doesn’t record anything in the track.
(I have tried both midi track & instrument track for this and it is just not working)
I had selected “all input methods” during recording, and when I go to studio setting, my keyboard does appears as “Active”.
I have tried to install several midi device managers and this doesn’t work too.

My keyboard model is Technics SM2400, and I connected it via usb to my computer.

Hi and welcome,

Remove all Devices from the MIDI Device Manager, please. Make sure the MIDI Input port has not been used in any Studio > Studio Setup > Remote Device. If there is any, set it to Not Connected. Make sure the track is Record enabled.

If t doesn’t work, attach some screenshots, please.

-Set the MIDI input to the dedicated port instaed of all MIDI ports
-Disable all record MIDI filters in preferences.

1 Like

Hi,

…good point. Preferences > MIDI > MIDI Filter. By the default, only SysEx is enabled. Also make sure the Channels are not enabled here (unfortunately the GUI is not really clear here, the slightly lighter channel button means, the channel is enabled - disable it).

Hi,

one more hint (ran into the issue myself yesterday).

Check, that the Record-Button for the track is enabled (marked red). I do not mean the Record Button on the transport panel.

Cubase also has some settings in “Preferences”, that influences this. There, you can enable/disable whether the Record Button gets automatically activated, if clicking an instrument or midi track.

Had this problem last night after installing a Nuendo trial version.

This helped me a lot! Thank you all for helping :slight_smile:
Much appreciated!
Best regards

Hi,

The button is named Record Enable.

Preferences > Editing > Project & MixConsole…

  • Enable Record on Selected Audio Track
  • Enable Record on Selected MIDI Track

By default both of them are enabled.

Hi, thank you so much for your reply!
I have disconnected all the remote device but it is still not working :neutral_face:
I couldn’t upload screenshots here directly because of the system… the links are the screenshots, hope you dont mind. Thank you!

https://i.ibb.co/RDnySc2/01.jpg
https://i.ibb.co/TwMxHvk/03.jpg
https://i.ibb.co/C9FF2dm/05.jpg
https://i.ibb.co/bm21cwC/06.jpg
https://i.ibb.co/sPGvkJR/07.jpg
https://i.ibb.co/Fs3Yr43/08.jpg
https://i.ibb.co/YksR6pp/17.jpg
https://i.ibb.co/rMYHjcL/18.jpg
https://i.ibb.co/Yc5g50P/19.jpg
https://i.ibb.co/ZLth28b/20.jpg
https://i.ibb.co/2vX7tyP/21.jpg
https://i.ibb.co/fpV0Mzr/22.jpg

Hi, thank you so much for your reply!
I had checked the setting and it is enabled, it is still not working :neutral_face:
I couldn’t upload screenshots here directly because of the system… the links are the screenshots, hope you don’t mind. Thank you!

https://i.ibb.co/RDnySc2/01.jpg
https://i.ibb.co/TwMxHvk/03.jpg
https://i.ibb.co/C9FF2dm/05.jpg
https://i.ibb.co/bm21cwC/06.jpg
https://i.ibb.co/sPGvkJR/07.jpg
https://i.ibb.co/Fs3Yr43/08.jpg
https://i.ibb.co/YksR6pp/17.jpg
https://i.ibb.co/rMYHjcL/18.jpg
https://i.ibb.co/Yc5g50P/19.jpg
https://i.ibb.co/ZLth28b/20.jpg
https://i.ibb.co/2vX7tyP/21.jpg
https://i.ibb.co/fpV0Mzr/22.jpg

Hi,

From the screenshots everything looks just OK. I just don’t know what is the Remote Device “Controller (XBOX 360 for Windows)”. Is any MIDI Port used here?

Could you add one more screenshot, while recording? So we can see the incoming MIDI Activity in the Transport Panel and not a MIDI Meters on the track?

Are you sure some data is sent at this MIDI Port? Myself I would go for the All MIDI Inputs option.

One more think, isn’t the data blocked by a Chord Pad? Could you double-check this settings in the Studio Setup, please?

I’m new to Cubase and I don’t use MIDI too often, but don’t you have to use the pen/pencil to draw and event before you can record and use the editor?

Hi,

No, you don’t have to. While recording the MIDI Part is created automatically.

The first image shows midi being routed to Microsoft Wavetable Synth. Am not sure, whether this could be the cause for “no sound”.

As a double check, add an Instrument Track with Halion SE being used as the instrument. Then add an instrument patch to the first slot of Halion. E.g. some piano.

Then route the output midi channel to the Halion SE (… instead of Microsoft WT Synth).

Hi,

Yes, you are right. But I expect the problem here is, the data is not recorded at all. Not that the data is recorded, but you can’t hear them while playback. Am I right?

The Microsoft Wavetable Synth is mostly routed to an internal Audio Device output.

I agree with the idea to try with an Instrument track (HALion Sonic SE).

HI. I am also having difficulty getting Cubase to record my keyboard. I’m using a Lambda interface. Only trying to input keyboard and recording. Shouldn’t be so difficult. :frowning: Monitor is showing in bottom right of screen so comupter is receiving a signal. Just not showing signal on my track and is not recording anything when I play. Not showing anything being recorded. I have checked midi settings and stuff. Like I said, shouldn’t be so hard. Got some answers pleeeese. Spending days on this now.

Hi,

What kind of instrument do you refer to? Does it have own sounds?

What kind of track do you make?

Same here: Midi monitor shows input signal when I press a midi key. However the midi-track does not receive the midi signal.
I use an M-Audio usb keystation mini 32 midi keyboard on Windows 10. Works ok with other sequencers and older versions of Cubase.

Hi,

What is the input of the MIDI Track? Is it All MIDI Inputs? How is the All MIDI Inputs set up in the Studio > Studio Setup > MIDI Port Setup? Os your wanted MIDI device enabled for the In All MIDI Inputs?

Disable MIDI filters.

No midi filters active(except sysex)(ps. I have +25 years experience with Cubase dating from the Atari days, so I wouldn’t ask if I tried everything first)