Cubase issues with HiDPI and VST3 plugins of some Developers

I have a HiDPI laptop and cannot use certain developers VST3 versions of plugins. The equivalent VST2 versions are fine.

I suspect it’s not a Cubase problem, but I wanted to know am I the only one experiencing this. Does anyone know anything about it.

What happens is, the gui either

  1. opens up too small and resizes itself to the same size as the VST2 version i.e. the proper size.
    or
  2. opens up the right size (same size as the VST2), but then resizes itself to a huge size too large for the screen .

Changing ‘Always on top’ can change the behaviour from 1. to 2.

The result is that I don’t use VST3 versions from certain developers. This needs to get sorted before Cubase 13 or whenever VST2 goes.

Examples of developers where VST2 and VST3 are fine and behave the same way.
Steinberg
Synapse Audio
u-He
Roland

Examples of developers that exhibit the VST3 gui resizing issue.
Cherry Audio
Valhalla
reFX
Tone2

The settings I’m using are:-

windows scaling 200% (recommended)
cubase scaling enable hidpi > yes

cubase scaling application scaling > -50% = gui opens small and resizes itself to correct size, or opens correct size and resizes too large for display (changing ‘always on top’ interferes with this situation)

cubase scaling application scaling > windows scaling setting = gui opens larger than the vst2 equivalent, too large for display, and with no resizing to correct size

SYSTEM
Lenovo t540p i5 2.6Ghz (runs @ 3+Ghz), 16GB, 2880x1620 (latest drivers as far as I can tell)
Audient iD4 MkI, drivers firmware 1.0.5 (latest), iD software v4.2.1 (latest)
Windows 10 Pro, 21H2, OS build 19044.1469 (latest)
Cubase 11 Pro 11.0.41 Build 448 (latest) HiDPI on
Reaper 6.44 (only used for testing purposes) DPI aware

That was supposed to say

Reaper 6.44 (only used for testing purposes) DPI unaware.

I’ve since discovered that when Reaper is using ‘Multimonitor aware (recommended)’ settings, the VST3 versions don’t do the resizing, the same as the VST2 versions don’t do the resizing.

This now suggests to me that Cubase in not fully aware, and that it is not coping with things that Reaper can.

I had this with a few plugins on a multi-monitor setup (One was ample sound bass plugin), and I think it’s because my second monitor has no scaling - because if I drag the plugin across to the 1080P screen it’s fine.

Like you, I tried REAPER’s options a comparison, and that seems to work fine. But there’s some decent options available vs Cubase.

Are you running single or multi screens?

Myself, I’ve just turned off HiDPI on windows and Cubase as it’s just a pain - If I get all plugins looking good the main track and waveforms can look blurry in Cubase which annoys me. Makes me feel a bit headachey some days though, working at a low DPI.

I’m just running a laptop t540p with no additional screens.

It is an unusally high res display and it doesn’t look good at all with HiDPi off. Everything is too big because the Cubase scaling gets deactivated with HiDPi off.

Maybe I’ll just keep fingers crossed that there’s some new handling in Cubase 12.

It’s just strange that VST2 is better, as if not all developers have got everything right in their VST3 versions yet.

Yet, the fact that some developers VST3 versions are working fine in Cubase, implies that Cubase is fine.

I’ve done some further testing and found that the windows scaling setting of “200% (Recommended)” is whats causing this problem.

If I set it to 100%, all VST3 plugins exhibiting this behaviour, behave the same as the VST2 versions, i.e. correctly.

But it’s not possible to leave it on that setting as Windows is unusable (unless using a telescope).

I’ve checked the graphics drivers and I’m on the latest.

I guess my only option is to stick on the last VST2 version of Cubase until I need to buy a new laptop.