Cubase keeps asking for old version of Spectral Layers

The studio I’m working atm recently upgraded to SL Pro 8. Elicenser shows the license installed. Standalone version works fine. The problem is that Cubase is always asking for the previous version SL One 7.0.30 .dll path even if i uninstalled it.
If I reinstall version 7 everything works fine (as long as it overwrites the vst3 file).
I even tried to install SL One 7 standalone only so Cubase can find the path it is asking and use SL 8 Pro vst3 file normally , but then it crashed.
I tried all possible combinations but I still havent found a way to make Cubase “see” the new version.

Any ideas?

You might want to post your OS.

Sorry, Windows 10

You might want to search in “appdata>roaming” to see if there aren’t any remants of SL One 7 and delete those files.

You also might want to consider something like Glary Utilities to help you clean out obsolete files.

I’m afraid I’ve already done that. Deleted every reference of SL 7, even registry cleaned. Cubase will not “see” SL8 always asking for the path where the original SL 7 should be. As I said Standalone works fine but not in cubase.

Well, I’m out of ideas. Sorry about that.

There have been a few other threads along this line. Perhaps Robin will chime in.

I would uninstall 7 and 8, then reinstall 8.
You may have already done that sequence

I already have followed this order. and registry cleaned for traces / deleted any leftover files etc. From what I understand is that when 8 is installed the vst3 file is replaced, in my case Cubase keeps asking for the version 7 engine (.dll file) pointing to the spectral layer 7 folder located in steinberg - program files. The 2 versions dont seem to coexist within Cubase

Just curious – does Cubase support ARA?

Yes I’m also using Melodyne in my system through ARA with no problems. SL 7 One through ARA as well.

Upgraded my SL7 One to SL8 One a long time ago, and it works as it should.

EDIT: Cubase Pro 11, Windows 11 Pro - Latest updates.

Well , to me Cub 11 Pro with SL8 Pro still make the issues I described
I can only use SL8 Pro in standalone

Hi @diaolosh , it seems to be a registry issue, please launch regedit ([Windows]+[R], then type regedit).
Then go to HKEY_LOCAL_MACHINE\SOFTWARE\Steinberg\SpectraLayers and either delete everything in there and reinstall SpectraLayers Pro 8, or just edit the values of ApplicationPath, EnginePath and Location to make it point to SpectraLayers Pro 8 instead of 7 (just make sure SLP 8 was the last installed software though, so the vst match).