Cubase keeps losing Generic Remote port assignments


It’s all in the title, really. In Remote Device, I have a custom Generic Remote device. Every once in a while (there is no pattern I can see in this), the MIDI Input and Output assignments are lost (“Not Connected”) and I have to reassign them again.

Any ideas? Is this a bug?


I guess, you are using some software, which creates a virtual MIDI port.

Unfortunately, most of the SW, which are creating a virtual MIDI Ports look like a new MIDI Device, from Cubase point of view. For every single start, the 3rd part software generates a new unique Port ID, so Cubase doesn’t know it.

Thank you. Yes, I’m using Lemur Daemon. Isn’t there can be a way to fix this, e.g. by referring to the port name instead?

No, developers cannot rely to the Port names. This information about the port is very dim.

Myself, I already asked some 3rd party developers to fix this on their side.

“…and we’re sending people to the Moon.”

Thanks a lot, not in out lifetime I guess.


Would using the IAC bus in Audio Midi Setup be a workaround for this?

I could try that, it’s true that Cubase never loses the IAC bus assignment I’m using for sending MTC. I’ll write back if I can get this to work with Lemur.

EDIT: Setting this up was trivial but I’ll only be able to confirm the setup is holding after several days’ worth of work. It seems fine, though. If this solution works you will have made my day and probably a bit more :slight_smile:

Well, a day’s worth of system restarts and multiple project openings seems to confirm that this is a solid-rock solution, SteveInChicago. Thanks a lot again!

This is really intriguing. I am having the exact same problem. I was wondering if anyone here could tell me how I use the IAC bus assignment? I only moved to Mac last month so I still am getting up to speed. Having to assign the Generic Remotes on every start up isn’t fun

It is very easy. An IAC bus is just a virtual MIDI connection that you can create yourself to transmit data between applications.

Launch “Audio MIDI Setup” from the /Applications/Utilities folder. Read the first part of this easy Ableton Live tutorial. The IAC bus you create in that tutorial should be used as the input for the Generic Remote in Cubase. You then set the same bus as the MIDI output of whichever application you need to send data to Cubase.

Thanks a lot! This bothered me for months!

i just keep exporting the xml file and import it if it does it

Hi Altostratus, I’m curious how you got Lemur to point to the IAC bus? I know how to create one in the Audio/Midi Setup App, but I’m not sure how to get Lemur to point there.


Same here, don’t know how to make it work with Touch OSC/Android

I don’t know about TouchOSC and Android (haven’t used that for ages), but for Lemur on the iPad it’s very easy: on the iPad tap the wheel/settings icon, “More Settings…”, then in the MIDI 0-7 list tap the “From” and “To” fields where you can select your Mac’s IAC bus.

This presumes, of course, that you have a Mac, that the iPad is on the same WiFi network, and that you’ve created an IAC bus in the first place :slight_smile:

Thanks, doesn’t work though.
I suppose it’s because it’s an Android device and cannot access apple’s wifi midi system natively but only through ToucOSC’s own solution.

I don’t think it has anything to do with that. IAC is Apple’s “Inter-Application Communication” driver and has nothing to do with WiFi. It only connects between different applications on the same computer. In this configuration we are simply using it as a relay, a lot like an extension cable.

When I open the “More Settings” option on my iPad Lemur and tap any “from” or “to” option, I can see all the MIDI inputs I have on my Mac, including my USB audio interface and everything else. IAC is just one more option among them.

I may state the obvious, but are you sure the Lemur Daemon is properly installed and running on your Mac? Your tablet Lemur app won’t see anything without it.

Hi. I have setup the IAC driver with 7 buses (0-7-as recomended in the metafader setup guide ). I am getting some problems including Cubase returning to the start position every time ( even though this is not selected in my preferences). Can someone clarify exactly how best to set up the ports in Cubase please?
I am on Cubase 8.5 and using arts unmuted meta fader with lemur on an iPad