Cubase Kontakt Performance

Hi everyone,


I’m having performance issues in Kontakt.


I’ve just bought a new 8 core Mac pro - I’ve not upgraded the RAM yet so it’s got 12gig but I’m having the same issue on my previous mid 2010 mac pro.

Real Time peaks are causing cubase to glitch. I’m using emotional piano, and I can see the real time peak meter spiking when a chord is played. Anyone got suggestions?


Michael

Welcome to the club sir…

Turn off multi-core support in Kontakt options and see if that helps.

Cheers for the response guys. Yeah I’ve turned of multi core support. My problem isn’t quite as bad as yours bigboi … How does it help if you turn off record enable because I know with asio guard record enable puts more pressure on the system.

Oh my god.

I had no real time peaks in Cubase 7.5. Now i have Cubase 8.2 it’s about a third of the way full and cpu usage a third of the way full with ONE KONTAKT PIANO (Hammersmith). I can’t even play a Berlin Strings legatos multi as the cpu maxes out in both cubase and kontakt (and the computer’s real cpu usage is about 2pc!!)

This is like Cubase 5 days. What a joke.

I have a mid 2010 Mac Pro and NO problems with spikes. A while back I read an article on how to CPU and disk manage Kontakt. Followed the advices and the result is no problems. If I recall correct the article was found at Impactsoundworks.

Exactly the opposite helped my performance issues (8 core CPU) against Steinberg recommendations. Turning on multicore support helped my CPU spike issues immensely.

I could recite that article off the top of my head. This isn’t simply a multicore on/off issue or another preference/Os fault. There is something in the build causing this or its a case of the transitioning between versions. No tweaking will work because everything has already been tweaked to death with the previous issues in 5-7. A clean install may do it which is a total pita doing that all the time.

If you get desperate rewire in Reaper and load kontakt in that.



Is a ridiculous solution but I’ve tried phoning Steinberg about it and when I suggest there might be a performance issue in Yosemite/cubase8 I get irritable Germans telling me there isn’t a performance issue.

It’s Cubase doing this to Kontakt, and it shows up more clearly in some Kontakt programs than others. Despite whatever irritable Germans say, this has been around for a decade or more. It’s a fact. Try any other DAW and you will see that this doesn’t happen to Kontakt - except for in Cubase.

Perhaps there is some homebrew hack you can find to clear it up. Don’t be afraid to experiment without any logical plan. Try anything and everything, as long as you remember how to reset it if it makes things worse, or that it might affect Cubase’s performance in other ways.

If you find something that appears to work, be prepared that it might not work after restarting your computer. These things are often inconsistent.

Sorry to say you shouldn’t be surprised if you won’t find any fix. Like some above posts said: Welcome to the club :confused:

I am so close to dumping Cubase for this reason . . . AND generally bad performance in 8.02.

I also own Pro Tools 11 (because most of my clients use some version of it) and I can load the exact same combinations of plugins - including Kontakt - and the machine barely breaks a sweat.

I know I could spend another week trying the 1000 tweaks that many people have posted here and elsewhere . . . but . . .I really don’t want to.

I kinda feels like the whole performance thing with Cubase is going in the wrong direction.

I’m open to ideas but teetering.

Hugh

Are you guys all on Macs that are having problems? I run Kontakt instruments in single instances and on a measly quad core i7 with 32GB ram, I can get up to 50 separate Kontakt’s running without a glitch including generous FX…

Please, give me your secret!

I’m running (as in my sig) on an old i7 with 12 gig of RAM.

Thing is, I have not had this problem until now:

  1. I upgraded to C8.02
  2. I upgraded to Komplete Ultimate 10.

Komplete is running on an external USB3 SSD - TI USB3 card PCIe.
I already had the latest Kontakt and it was not upgraded.

I’m building (have all the parts) a new 6 core 5820K on the X99 platform. 32 gig of RAM to start.
But the issues (whatever they are) that are bogging down this machine will do the same to the new one - just a lessor extent. So I really need to figure out what the issue is.

Main thing is when I run 1 (ONE!) instance of Kontakt with an intense patch (Like Modern Drummer) in an otherwise nothing project I get these spikes every so often. Even with the track NOT in record (ASIO Guard in effect).
They ARE audible.
There are a lot of people here getting the same kind of spiking but in different situations.

I can’t help but think it’s something with the “New Audio Engine” that is just not playing well in several different situations (Kontakt being just one of them).

Steinberg seems to be clueless on this issue - or keeping silent so as not to acknowledge an intermittent problem.
Really not sure what I’m going to do.

Hugh

PS NOT moving to Pro Tools. I don’t have their hardware dongle so I lose too many features.
But another DAW? Possibly . . .

1 Like

I just fixed all my problems with a few things.

do the following.

1- change disk pre load to 2 Seconds… try one second. after each change hit apply on each change.

2- disable the stupid auto record enable setting that creates havoc.
“Enable Record on Selected MIDI Track” found in “Preferences → Editing → Project & MixConsole”.

3- leave Asio guard on & change your buffer settings to find what works best.

4- With kontakt cores TRY OFF FIRST

Then follow the attachments.

Lastly I see the mac terminal hack, I have not tried this yet but seems to be really working for everyone.

terminal Hack

I still find cubase 8 a little buggy, even on a totally new system… just proves it’s not our computers and could be cubase?

regardless these small fixes really fixed up performance for me & a few friends machines as well.

This:

. . seems to have fixed my spike problems.

I applied it ONLY to Cubase 8 - not any plugs.

For now I am MUCH happier.
I really hope I’m not speaking too soon.

Hugh

I’m having similar issues with Kontakt in Cubase 5. I recently had to replace my broken iMac with a Mac mini, but I managed to get one with matching specs. I migrated my data from a backup drive so all should be the same - however, since the switch, Kontakt’s memory capacity is very low to what I’m used to (around 200MB max) so it’s very easy for me to overload Kontakt when adding multiple instruments, causing Cubase to crash. The only major difference between each machine is my iMac was running in a much older OS, I think Snow Leopard. My Mac mini is running OS Sierra as it is brand new.

Specs:
Mac mini late 2014
2.8GHz i5
16GB RAM

I used to be able to load much more in Kontakt, and older projects now cause Cubase to crash before they can open because of the amount of instruments I was previously using in Kontakt.

Is there something I can change in my settings that will allow for Kontakt to store more instrument memory? I can’t imagine why any of my settings would be different because of migration but I’m not sure. My DAW CPU meter still remains very low so it seems like just a Kontakt overload as opposed to anything else.

Any help would be greatly appreciated, I’m very reliant on my sound library within Kontakt which is now more or less impossible to use, not to mention not being able to open old unfinished projects, big problem!

How many cores was it in the iMac and how many in Mini? And how do you set up the different Kontakt Instruments?

One instance of Kontakt adresses one core as long as there are cores available. The more cores the lesser strain on the CPU.

If you load several instruments into ONE instance of Kontakt, all instruments will be sent to the same core. Multies behaves the same way. So:

  • As many cores as possible (when you buy the computer)
    One instance of Kontakt per instrument
    Avoid multies.

The same applies for some synths like Omnisphere.