Cubase & Kontakt - Realtime Performance Problems

I’ve been working this problem for a while… still not happy. Here are the details.

Cubase 9.5.41 and Kontakt (up to date and multiprocessing is off) on Win10 64bit with RME AIO (updated) and NVIDIA GT1050ti
Intel i7 5820K (6 core, 12 threads). Memory tests are fine. Operating is on SSD for OS and SSD for samples.

Previously this system could run hundreds of channels of VSTs with many instances of Kontakt at ulta low latencies… no problem. Now just one instance of Kontakt playing a piano patch or a Spitfire sample, and the Real Time Performance monitor will clip constantly at any buffer setting. It’s completely unusable.

I have completed the Windows configurations, and even tried the Win10 dropouts suggestions ( without benefit.
Latencymon shows no problems.

Where do I go from here?

Since your system previously ran well, what have you changed recently? Cubase update? Windows update? Kontakt update? Hardware? Etc…

This will give us a better understanding when helping. :slight_smile:

What I mean is what were specs the last time your system ran really well.

It’s hard for me to pin down. The last couple of projects have been mostly audio-post using Nuendo. I believe the problem occured after some updates to Windows and NVIDIA drivers. This happened before, and I resolved it by removing NVIDIA drivers and using generic Win drivers.

Thinking I might buy a Radeon card and see if this makes a change. Upgrading the NVIDIA chip certainly didn’t help.

Using ASUS X99-A 3.1 with latest BIOS too. Haven’t checked BIOS settings or tried disabling HT yet…

I think all these reports lately with dropouts and real time performance problems - with virtually no assault on computer at all - is different sides of the same problem.

I get clip in realtime performance - no tracks, just Cubase idling - and some minor system event hourly all day long.
So it is detected as dropout - but seems like something internally is seriously wrong with audio engine.

I run Sonar and Reaper with no sign of these effects that Cubase produce. Not a pop or anything, and certainly no interrupted recording saying “dropout” and transport stops???

I filed a ticket to Steinberg yesterday making a video of the fenomena - how Cubase goes bezerk over nothing, restarting 7 threads over this claimed “dropout”. In my case this hourly thing - is on the second of every hour systems been up, so easy to pinpoint.

So this realtime performance clip, red bar, is making Cubase take all kinds of actions - probably for no reason than some internal fault in audio engine.
It’s not even a cruise in cpu on any core over this - but Cubase takes out the big gun.

Hopefully Steinberg sees these reports not as local problem for each individual - but as a sign that something needs to be looked at.

Even though I run Cubase on a Mac, I have two PC slaves which I got rid of any NVIDIA drivers because they completely messed with real-time audio processing. I now run my PCs through Remote Desktop because of this. Latencymon barely reports any issues now.

Also, I’ve read on other forums where members who use Cubase in Windows say AMD gfx cards work best. I know this isn’t encouraging, but it might be worth to test uninstalling your NVIDIA drivers and try out Cubase to see if there’s a difference. If not, then that saves you money on buying a new card and we can start looking elsewhere for issues. If it does affect it, then you found your problem. :slight_smile:

It could be a windows update
Windows 10 KB4100347 update is known to cause trouble and the latest Windows update in October 1809 incorporated it in a fixed way that you cant remove.

Look up Broadwell Haswell-E and asus 99 KB4100347

If you find you cant overclock then you are affected

PC will only run at stock and all the normal tweaks for audio like fixing the clock speed and power saving disabling etc no longer take even if you change them in BIOS

Just a thought


AMD Radeon card ordered yesterday. Fingers crossed… but very sad by the return of the configuration blues. I lived through this from Win 98 until Win 7… and it has been Heaven for the last couple of years of stable EXCELLENT performance.

Wish me luck.

More info… this is definitely not related to Cubase. I’ve loaded Kontakt in standalone and experience extreme glitches then too. Running LatencyMon and the reports are bad… so I’ve edited my thread title. How bad? Check out this attached image.

This happened after diabling HT in the BIOS.

What is your current version of Windows 10?


I think the values of LatencyMon are correct, I get the same with DPC Latency checker from

Difference is that LatencyMon introduce so much load, that starting Cubase it hits clipping peaks just idling - 100% of the time.
Exit LatencyMon and normal peaks in Cubase are 25-40% on my system, even running a project.

I got max 11000 something on ISR with LatencyMon running and Cubase - what is caused by LatencyMon?

DPC Latency checker is smooth and can be run together with any application.

And you get a nice history graph ticking forward.

Nice with suggesting a driver with LatencyMon, but works only in an idling system - and what is activated by a daw is not there.
You get no interference for DPC latency checker.

Win 10 v1803 Build 17134.345

Good tip. Thx!

Update… I removed the NVIDIA card in favor of an AMD Radeon RX570. This instantly improved, but didn’t fix the problem. The latency reports all continued to show errors (fewer) but they were related to other USB drivers, etc.

My next step was to completely nuke Win 10 and Reset the OS. I clean installed Cubase 9.5.41 and Kontakt 5.8.1. This was THE BEST performance I’ve had in more than a month. My “testing library” is the 8dio 1928 piano. Before, any sustain pedal playing would clip the RTP meter and spike Cubase outputs. Now it performed well… but here’s the STRANGE observation… this was with Kontakt Multiprocessing Enabled.

Typically, I’ve had trouble when both Cubase and Kontakt have multiprocessing enabled. The old solution is to disable Kontakt MP support. I did this on the clean install, and everything went to sh!t. Terrible performance. Enabled the Kontakt MP support again, and the performance was improved. Still not amazing, as the instrument will clip the RTP when releasing the sustain pedal… but it’s at least workable.

What are your experiences and current settings for using Cubase and Kontakt together? Multiprocessor support enabled in one or both?

Just thought I’d bump this thread…

I thought I had fixed my problems… a new video card (AMD), a fresh OS install, memory tests are ok, Latency Mon is clean and clear… I’ve started getting regular real-time peak glitches again. Even without a project loaded… the meter will bounce, and about once per 15sec it will spike. The problems are not nearly as bad as before, but this is still not behaving well enough for a professional environment.

What else can I do?

Even selecting menus will have a delay between the drop down and the menu populating with text… small but noticeable latency

Did you solve your performance issue? If so, would be nice to hear what was going wrong…
all the best

The problem is solved in Cubase 10.0.30 but remains a problem in Nuendo 10 (current version).

I’m working a Nuendo post job right now… loaded Kontakt with Spitfire Melodica Labs patch (small, simple)… and the RTP Meter peaks with every note. Save and open project in Cubase 10, and RTP meter is barely moving.

It might happen when Cubase is loading projects, data, libraries and large quantity of wav forms from other hard drives. If you have the external drive where you store your data/sessions/content libraries - upgrade to SSD USB3/Thunderbolt. It is the data transfer issue.

Sorry… but I have 6 internal drives and all that hold samples are either SSD or M.2. That’s not the source of the problem.