Cubase Launch Hang/freeze stuck at SKI Remote.

Hey Guys,

Seems as though everyday Cubase 7.5 is slapping me with a new issue. Today Cubase wont open. Its hanging and freezes as soon as the load hits SKI Remote. Last night it was working fine. No changes made since. I found another post about this in here but its from 2011, for C6 & no solutions or responses posted to it.

I uninstalled the SKI remote cubase opens fine. I reinstalled it. Same problem. I do in fact use iC pro, for remote recording from the booth.

Can anyone help resolve this issue ? bonjour is installed etc.


Ive logged this with support to see if there is a known issue. Will have to without iC pro control for time being.

I uninstalled everything related to Steinberg as suggested by technical support and then reinstalled 7.5. - I then installed the update and SKI remote. Before adding the remote in devices cubase opened and operated.

After adding SKI remote in devices, i got elicneser control message - "The license for application ‘Cubase iC Pro’ will expire soon. Duration until expiration: 4 Hours 41 seconds.

Anyways i clicked ok and both cubase and ic control worked. Then i quit and tried to reopen and I am back to square 1 cubase wont open. Hangs on SKI remote.

Just keeping this thread updated.

I’m having this issue also in Cubase 7.0.7.

I recently changed to IC Pro on iPad and wondering if it’s something to do with that…


I am currently talking to 2 tech support guys and neither can find solution yet. The problems comes across like android license issue but we are using iOS. Can you please log your issue with support, the more people who log it, the quicker it gets fixed. If you find solution please post. I will post the same.

Hmm… Not sure what’s happened but this morning when I loaded Cubase it said something like ‘Your Cubase 7 Trial is over - you can no longer use this software’. A bit strange since I never loaded any Cubase trials…

Then Cubase 7 just loaded as per normal - so I closed it, restarted and now it’s fine. I no longer have this issue. I did absolutely nothing!

Lucky you haha. Mine worked fine and then when it stopped working it was presenting that license expire error. I wonder if it has something to do with changing from the free iC to the pro.

Anybody resolve this… Updated everything including Cusbase 7.5.20 …no joy.


A cubase staff member on gearsluts told me download this older version of the SKI remote. Its the only thing that worked for me.

Hi Folks

A big thanks to realizment2 as the downgrade of the SKI remote did the trick. I now get a warning on the iPad that I am using the old software, but no big issue!

For reference, this seems to have occured after a Windows 8.1 update today from our friends at Microsoft. This is getting pretty annoying and I sympathise with the support team. Hope they get a heads up before next months “update”.

Hi Folks,

I have the same problem (Cubase 7.5.30).

The older version of the SKI remote software (1.0.5) seems to work but the new one hangs.

Is there still no other solution than accepting the “The SKI Remote extension is not up to date…” message everytime using Cubase IC Pro?

Thanks for any replies.