Cubase LE 5 registration not working


I recently downloaded Cubase LE 5 from a CD I was given with the Lexicon Alpha desktop recording studio (the box included both). I have to download Cubase first and after, I could download the desktop recording studio, however, after I open Cubase LE 5, I am asked to register which I do want to, but whenever I click on the option I get transferred to a website that is unavailable or not found. I’m in need of some help.

Since the software version is 12 years old, this must be an outdated link.

The registration you should be concerned with is in the Elicenser Control Center

I tried many things with that too. I downloaded the latest version (e-Licenser) and tried to register with the one soft-eLicenser that the program shows, but when I do, the registration does not give me an activation code with the registration. There is a pop-up guide that shows how to fix this issue but it didn’t help unfortunately.

The activation code is on a paper that came with the Lexicon device.

Also, Activation ≠ Registration

Found something interesting. I downloaded the latest version of eLicenser yet when I type the activation code/serial number in, it tells me that I’m using an outdated version of eLicenser and I should download the latest, but I have the latest version right now.


You must be typing in a download code. Open the Download Assistant and type it in to the upper left corner where you see the prompt for that number.

I apologise for pretty much wasting your time with this but could I ask what the serial number is for? I have it on my Cubase LE5 cd case.

I don’t know.