Cubase LE 5 (Tascam Bundle)

Hi, I have ordered a Tascam US-1800 (actually 2-one a gift) on USA, It come with Cubase LE 5, within the Tascam Logo, it’s fully operable software, I have tried until the trial, times out. It do not Inform or Support the question in able time since I have purchased the Interface.

On Windows 10 Tascam US-1800 just don’t recognize the drivers! And do not Interface Input of Audio, just like the support is out dated and in the middle time, product discontinued! I’m Having happy days with the Interface on Windows XP, but no audio insertion!

I want to know how to register Cubase LE 5 without registration or activation code refered? I have Including my old dongle extra point working for it, But it don’t seems to be needed as OEM. I don’t know, tell me what’s that what’s happening?

  • Another question is that, I can use Cubase 5 in 2 Dongles? - This question is secondary, seeying I can use it automatically installing it using the Activated dongle, but If I can use both I can use the other internally. Don’t lath but that is stronger than the old one. Even like this so big and measurable. I see that as only one thing, it must be a space combination of things, with no think!


To get an Activation code for Cubase 5, follow this article, please.

No, Cubase license cannot sit at two USB-eLicensers. If you want to use 2 computers, transfer the Soft-eLicense to the USB-eLicense (you need an USB-eLicenser). Then Cubase starts at the computer, where the USB-eLicenser is plugged in.

My eLicense which was not responding or registering before is now Responding on Dongle as Activation. Cubase LE 5 Activated!

Sorry, but what you’re saying is undefined, seeying that the activation are prompt to the view even in other dongles.

This software have a so easy view, practical manual, categorized and modern words in the learn, but we are not at the same point!

On this version I can Use 64bits Plug-Ins? I can’t see that functioning or having it as version to the installation setup DAW, only 32bits. I know that work for Cubase 5. I know this is available to me to Download as update. But it’s offered as promotional, not free. I will probably have a 64bits version updated to the LE version 9.5 in a very bit small price.

But what’s the truth? Working it for 64bits?

You can install both 32- and 64-bit version of Cubase LE 5. In 64-bit Cubase you can use 64-bit plugins.

Cubase LE 9.5 is 64-bit only.

I would recommend to upgrade to 9.5 to make sure your Cubase if fully compatible with the current operating systems.

Not functioning for CuBase LE 5 for Direct-X, not even being identified. It are not refered to 64bits on Install.

Whatever, I’m not worried about it. But’s not the truth.

All right, all stuff was going ok, without the fault of Tascam, after a compilaint, Insistent Update with no choice from Microsoft has appeared the following messages from the elicenser.

From Cubase eLicenser Control:
Soft-eLicenser don’t have enought permissions to run properly.
Please Run LCC to fix the problem

Running LCC to fix the following message appears to be sending a message to the server saying that to as uncorrigible fix.
Contact the software vendor to solute the problem.

The update seems to be nice from Microsoft on Windows 10 (another level of the front ending), but insteady just another change in ourself(s) to other fix.

Cubase 5 LE is running after the check and prompt, but the error message is alarming (prompting)! I don’t know how and what this are affecting from the original source of installation.


Right click to the eLCC application and Run it as Administrator. Trigger Maintenance. Quit eLCC. Now Cubase will start without the message.

It are running as administrator, how can I be more administrator than the time I leave for that!? Any change has not modified the situation and the functionality of Cubase 5 LE are partially compromised. Some Plug-Ins has just stopped the normal work!

I use the US1800 with Windows 10 without any problems at all.

Just to register, has worked as administrator, but for what in lane learn for cubase, some plugins can loose their compatibility, I’m trying to figure what has disabled to loose possibilities.

For what to figure, nothing can be reached, it just has changed what has been made. The dongle is just something apart to be decapitated anytime thru this fury!

After Re-install subscribing Installation setting, I have found no results. But trying it for the plug-ins I have found that the UAC can block to create certain process of files due to security settings. Wanting that to be changed from the prior to new one’s. It was a perfect plug-ins functioning, but therefore the updates changes has manifested hat the UAC Setting is not the same at the level of the settings before. The hint is that to disable and accept the entrance of the virtualisation without your security affirmations.

Anyway, I don’t know, I have no response about it, I have no response of it than the hint from the support which changes my up´levels!

I have found that updating with other cable my Tascam US-1800 started on my notebook, but actually that after the update, I have tried the same cable I use on my desktop, not worked! But not the gift, that is really with serious problem to that, maybe something is burned, it has happened after the try of use VB1 Red, the old one in version 1. It still turn on!

For what I’m studding I’m not seeing 64bits as the best option, it’s not making the difference they are wanting to stay on top. A 64bits architecture is fully of operating possibilities, but don’t sound best! In the contrary it tries more to make you less for the “already you are”.