Cubase LE 8 Video Player

My Cubase LE 8 program keeps trying to load Blackberry Desktop instead of Quicktime for its video player. Anyone have any idea why this is?
I am running Windows 10 Pro v.11068.


Is QuickTime installed (the latest update) on your system?

Could you write step-by-step repro, when does it appear, please?

Yes, my QuickTime is installed with the latest update.
When I open the program, the introduction screen appears and begins to load the different programs that operate within Cubase. When the process gets to the Video Player, a popup screen appears displaying an attempt to install Blackberry Desktop Software. It then asks if I approve of running the installation program from RIM. I approve it. Then a popup appears showing the installation of the program. Next, another popup appears stating that the driver publisher cannot be verified and do I want to continue with the installation. If I approve it, an error box comes up stating that an error occurred and my computer is not configured for the software. It then closes after I click on OK. Then it tries it again and again and again. If I click cancel, it just tries again. In order to stop this process, I slide the box down to reveal the program progress box where I have the option of aborting the loading of the video player. I stop it and the Cubase program continues to load. When it is finished, because there is not a video player associated with the program, only the title bar and menu bar appear. I can open individual windows using the menu but the main screen is blank. I am attaching screenshots of the process.
Any ideas?
Screenshot (15).jpg
Screenshot (24).jpg
Screenshot (27).png


This is really interesting. To me it seams, some components are messed up.

Could you try the Safe Start Mode, please?

Hi Martin. Sorry took so long to get back with you. Bad news - Windows 10 doesn’t have the option of starting in Safe Mode and the Cubase program crashed my computer big time. Luckily I have an external drive and was able to restore it. Cubase is gone though.
I don’t know what it did, but it did it good!
Any more suggestions?