Cubase LE AI 11 wont launch

Hi everyone! I recently purchased UR22C recording pack and Cubase LE AI 11 is included with soft e-licenser. I downloaed the Steinberg Download assistant and performed a full download/installation. Groove Agent SE 5 as well as HALion Sonic SE work fine. However Cubase LE AI 11 wont launch. I click the desktop shortcut but it just wont start. Has anyone else encountered the same issue? Thank you in advance!

Hi and welcome to the forum,

Are you on Mac or Windows, please?

If you are on Windows, I would try to uninstall Cubase and install it again as administrator.

If you are on Mac, I would try to delete Cubase from the Applications folder and install it again.

Do you have any previous Cubase installed on the system?

Thank you very much for the reply! I am on Windows. I tried uninstalling and installing Cubase again and it wont launch. But i reactivated it in another computer and it worked fine so probably its either an issue with my computer or with my windows I suppose.