Cubase LE cc automation lanes

I’m having the same issue as this user here -https://www.steinberg.net/forums/viewtopic.php?t=113938

My question is, does Cubase LE 9.5 allow the option to record CC data into automation lanes rather than overtop my MIDI track? I can’t seem to find the menu option, “CC Automation Setup”.

If LE doesn’t allow this functionality, does Elements?

Thanks.

Sorry, but this menu is only available in Cubase Artist or higher.

You’ll have to use MIDI -> Functions -> Extract MIDI Automation.

Thanks for the fast response. I had to look that up but I see how that works now. Not so bad but, once I extract, how do I remove the diagonal lines from my original MIDI event (if I double click event, there are no longer notes there)?

Also, does LE allow me to map hardware knobs and sliders from external MIDI devices? Having some issues with that as well.

Thanks.

Diagonal lines? Not sure if I understood. Extract MIDI Automation converts all of your MIDI CCs into automation, so any lines are supposed to be gone. Only pitch bend, aftertouch (including poly pressure), program changes and system exclusive messages aren’t converted into automation.

Cubase LE supports external MIDI controllers, but you can’t use VST quick controls. Only plugins that feature CC learn will be able to be controlled by your hardware device.

To check the limitations of Cubase LE, take a look at the manual:
https://steinberg.help/cubase_elements_le_ai/v9.5/en/Cubase_Elements_LE_AI_9_5_Operation_Manual_en.pdf

Press Ctrl+F and look for “not in Cubase LE” and “Cubase Elements only”.

So here I have diagonal lines running across my MIDI notes even after extracting MIDI automation. The automation is now in it’s own lane which is good, but those lines remain. If I double click to go to piano roll, the piano roll is blank, no notes appear. It seems there is some overlay still atop that track. If I use eraser tool on it, it removes the overlay but I’m not sure if this is the proper way to handle this.


Thanks for the info. I’ll search the manual.

Ah, I see now. This means that you have overlapping MIDI parts.

To stop that from happening, make sure that “Record in Editor” is enabled. By default it’s enabled by double clicking the MIDI part, or by clicking this button to the top left of the Lower Zone:

With this enabled, Cubase will record MIDI data inside an existing MIDI part instead of trying to make a new part.

Okay I see thanks. Is there a way to tell how many parts I have overlapping? I read up on it and I notice I have to click move to/back a couple times to get to my original part.

There should be a small down arrow around the bottom middle of the part when you highlight it, which will allow you to pick which of the overlapping parts will be at the top.