Cubase macro

I tried to write several macros, but it seems Cubase has a bug with it.
For example there is a macro: Transport to marker 1 --› Split at cursor --› Lock --› Decrement event volume (this last command for 10 times, for decrease 10dB).
When I use this macro, every time the result is different. One time it changes the order of commands, next time it performs the “Decrement event volume” command only 4 times, and so on.
Can someone tell me how to program macros to work as it should?

(I’m on Cubase 6.5.0, OSX Lion)

First of all, try to update your Cubase 6.5.0 to the latest 6.5.3 version. You can find the update here.

Try it again, you will see.

Thank you for your advice, I updated to 6.5.3, but the problem is still the same.

I check your Macro again. This Macro may not works.

There is Lock command. This one lock the region, and you can^t change the volume of the event.

I forgot to write that I changed the lock attribute only to lock position in preferences, so that is not the problem. This macro changes to volume, sometimes -4 dB, another time -1 dB, and so on. Sometimes it cuts the event where the cursor is, sometimes at marker 1. What’s wrong with it?

I check the Macro again, and I try to make it in my CUbase too. There is one more problem, I can see here. When you Split the region, there is no region selected after this command. You have to choose, which region do you want to edit. Left one (before curosr), or right one (after the cursor)?

You have to select one of the region (you can use any command again, of course). Then, you can set the Velocity. In your way, the Cubase shouldn’t increase anything. Because, there is no selected region.

I’ve tried that before, inserted the command “select event under cursor”, but that hasn’t solved the issue. I’ve even tried to put some pause like commands (for example “cycle” command) inside the macro, just to slow down the commands execution (I thought that maybe Cubase performs the actions too fast), but that neither helped.

It just works in my Cubase. Check the screenshot.

Cursor jumps to the Marker #1 position. Split the region of selected track. Select the region on the right side of the cursot (under the cursor), and Decrement Event Value 4-times, i.e. -4dB.

I tried it 10x, the same result, always.
Screen Shot 2012-09-04 at 12.51.37.png

OK, thank you, I’ve checked this macro on a new empty project with 1 track in it. It works. But if I’d like to use it with a project with around 20 tracks, some insert effects, the problem exists. What would you recommend to try changing in my project?

There is for example another one.

Locate next marker --› Select events under cursor --› split at cursor --› Navigate left --› cut --› locate next marker --› select events under cursor --› split at cursor

Cubase runs this macro in random order, leaving out some commands.
I tried with an empty project, only 1 track in it.
Does anybody experienced this weird behavior with macros?

What Cubase version, do you exactly have? Are you using 32/64-bir Cubase, What about your OS (Windows Vista/7; Mac OS X 10.5/6/7/8…?)?

Cubase 6.5.3, OSX 10.7.4, MOTU 828 mkII, Euphonix MC control

I’d like to use Cubase in 64 bit mode, but the shuttle/jog function not working just in 32 bit mode.
The macro problem is there both 32/64 bit mode.

I tried to disable Eucon, but that not helped.

Strange, I have very similar configuration (Cubase 6.5.3 in 32 bit mode, Mac OS X 10.7.4, Euphonix Transport, RME interface), with no problem.

I expected Windows, sorry! :smiley:

I tried this Macro on projects with more tracks (demo project of Cubase 4: Real do you remember it? and demo project of Cubase 6: Live Forever). I have no problem, again. If there isn’t marker 1, it makes strange things, sometimes. If there is marker 1, it’s perfect everytime.

Sorry, I’m afrain, I can’t reproduce your problem, so I can’t help you because of this, now.