Cubase MIDI Recording Double Notes on Channels 1 & 2 - Driving Me Nuts

I’m using a Yamaha P45 Keyboard plugged into a USB port to record piano parts to my tracks. OS is Windows 10, Cubase 12 Pro.

Whenever I play notes it records 2 notes on top of each other in the Midi event. One notes is set to Channel 2, the other to Channel 1. So far my only way of fixing this is using the Logical editor to delete everything where Channel = 2. It’s ridiculous and I don’t have this problem with my Casio Keyboard or with my UR22 Mk. II when using my old Keyboard and a Midi Cable.

These are my studio settings:

And this is the track setting:


Note: the Digital Piano is not “Missing” I just turned it off right before I took the screenshot.

I enabled the Windows Timestamp and I excluded Digital Piano from “All Midi Inputs” and, as you can see from my screenshot, I even stopped using “All Midi Inputs”. I can’t find any options anywhere for telling the piano not to send signals to Channels 1 and 2 simultaneously. Cubase can’t be told to ignore all but Channel 1? This really doesn’t even make sense because in Halion Sonic SE when I select any Midi channel besides 1 I get nothing, no playback at all.

Is there any way to end this nightmare so I don’t have to use the Logic editor to delete the Channel 2 notes after EVERY take? I wouldn’t care except the sustain of the notes gets screwed up when they’re on top of each other so the playback doesn’t sound right.


Have you turned local off on your keyboard in the midi settings?


Could you use MIDI Monitor MIDI Insert to double-check, the real input to the track? Is it possible, the hardware really sends the MIDI data on both MIDI Channels?

It probably does, but the P45 has like NO options to control that. Hell the thing only has a function button and all the functions I see in the manual are related to the built-in sounds, not output or MIDI.

Is there no way to prevent Cubase from writing an event on every MIDI channel it receives? I can’t have it only listen to Channel 1?


You can use Input Transformer:

Filter Target
Channel | Equal | 2

Action Target


Okay I will try that when I get home, hopefully it had a negligible effect on latency. Thanks!

In case this helps anyone in the future, I was able to address this issue AND find the cause.

What Caused My Issue: Using the dual voice feature on the Yamaha P45 Keyboard. When you combine 2 of the native voices like Piano + Harpischord or E Piano 1 + E Piano 2 it sends events for each voice on Channel 1 and Channel 2. Stick to just 1 voice and it only sends on Channel 1. This explains why this issue only happens with this specific keyboard.

What Fixed My Issue: Obviously not messing with the voices on the piano fixes it but also using the Project Input Transformer and filtering out Channel 2 inputs as Martin.Jirsak suggested also worked 100% for me. This is a nice solution if you want to use the piano’s voice options for personal reasons but don’t want the duplicate notes showing up.

Thanks everyone!