Cubase & Midi

I need to re route midi tracks recorded @ another studio.
I am using a Roland Juno G, & Focusrite scarlett 2i4 interface.
The audio tracks play back but the mid tracks don’t.
I can see the midi track meters working but no sounds.
How do I go about routing these tracks through my Juno G keyboard?

To play sounds from the Juno you would need to buy a usb midi interface. The Scarlett doesn’t have MIDI as far as I can see.

To play the Cubase VST instruments you need to add them to the instrument rack (F11) and then route the midi channels to the instruments…you don’t need an interface for this.

Thanks. The Scarlett does have midi in & out.

OK…so you’d connect midi out of the interface to midi in on the keyboard and then select the Scarlett MIDI port as the output for each Cubase track.
If the Juno is multi-timbral then you can set multiple channels to the same port but use different midi channels for each sound.

You could also use a USB lead to the JunoG along with loading up Roland’s USB Midi drivers. This would give you a special Midi device in Cubase which then transmits/receives Midi via USB to the JunoG - no midi lead needed. Also you could then use the Editor Librarian to edit the sounds on the JunoG using a nice big display rather than the smaller display on the JunoG itself.

I do this with my Roland Fantom X7, you have to change one of the system settings to be USB Midi, but I reckon it works with less latency than through a normal midi lead.

I haven’t got a JunoG but you’d need to put it into performance mode to get it to play from different midi channels simultaneously (multi-timbral).


Ok. I am using a Focusrite Scarlett 2i4 w/ midi in/out. How do you set the Roland keyboard up to play back midi files.
I set my Cubase track channel in through the Focusrite and set the out the same way. I have both midi & audio files in my projects. The audio plays but no midi. I can see all ther meters moving in thr midi files but no sounds.
I cant figure uot how to get the midi files to play.

You may be better posting this question in a Roland forum… But at the very least you should put the Juno into Performance mode. Then you’d need to dive into the performance settings to check the midi channels of the Juno tracks match those being sent out from Cubase, then you’d need to select some suitable sounds… A quick check of the Roland manual would help you out too.


Don’t you have to plug the audio outs of the Roland unit into the inputs of the audio interface, or at least a plug a set of headphones in the headphone jack of the Roland to hear the audio from it?