Cubase - NI Maschine faulty syncronization

I use NI Maschine 2.13.0 software as a vst in my Cubase 11 Pro (latest update). I set Cubase to repeat a loop of 1 bar. Maschine software listens to cubase and loops the same bar. I put midi notes on every beat of that bar inside Maschine software . The problem - My Maschine software does not trigger the first note of the loop/the note which sits next to the left locator. “Quantize” and “Grid lock” are set to on on both Cubase and Maschine - so that note does not extend before the beginning of the loop. In Cubase, the loop starts exactly at the beginning of that bar, NOT later (Quantize and grid lock is on)!
Is this a Cubase problem or a NI Maschine software problem? I just bought a new Maschine MK3 and if I cannot use the “Step” sequencer to insert midi notes on the fly in Cubase, I think that I will have to send it back and ask for a refund.
I recorded a video and I uploaded it on my google drive account, to clearly let you see what I am talking about. Unfortunately this forum does not let me add the link

Please try to recreate the situation and share your thoughts.

Does Cubase skip (an internal bug?) the first milliseconds of the loop, thus Maschine software does not notice the start of that midi note, or does Maschine software push that midi note to a position before the start of the loop/the bar where the Cubase loop starts?
I hope that I can get an answer soon enough, so in case the problem cannot be solved, I will be able to send the Maschine MK3 back and ask for a refund. Thanks!

I don’t know enough specifics to give you an exact answer but this sounds like a clock source and/or synchronization issue. I would start here:
https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/synchronization/synchronization_c.html
https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/synchronization/synchronization_project_synchronization_setup_dialog_r.html
Hope those help

Here is a good video that I watched to hook my old Maschine up. Don’t know if it will take care of your issue, but wouldn’t hurt to use it to double check your setup:

Also, this guy created a good thread on the NI forum with videos and instructions

@SF_Green Thanks for answering. How did you add your links to your post? I try to add the link of my video and it says “Sorry you cannot add links”.
If you would see my video, you would understand exactly what is happening.

I’ve got through all the things suggested by you and no help.
I really need to post the link to my video stored on Google Drive. How do i do that?

I sent a link and explanation by private message. Do you see a blue dot on your avatar in the upper right corner of the screen? Click it and you should get a drop down and see my message on what you need to do to be able to post links, files and pictures.

Here’s the bottom line:
Get to trust level 1 by…
*** Entering at least 5 topics**
*** Reading at least 30 posts**
*** Spend a total of 10 minutes reading posts**
Here’s the whole topic

Here is @Marian 's video link describing the topic:

Thanks for the help, SF_Green!
Please watch with the sound level up and notice that the midi note is not played when placed next to the left locator (although is still inside the loop and the loop in Cubase starts at bar 2, right before the midi note).
Looking forward for your opinions and advices.
Thanks!

OK, sorry it took a bit to get back to this. I see what is happening and I can reproduce it on my system.
I tried various settings that I thought might fix this but none worked. I especially thought this one would do the trick: the MIDI section in the Studio Setup has the Use System Timestamp option that I hoped would fix this, but it didn’t.

Use System Timestamp for ‘Windows MIDI’ Inputs
Activate this option if you have persistent timing problems such as shifted notes. If this is activated, the system timestamp is used as a time reference.”

I also tried the Preferences MIDI setting “Extend Playback Range of Notes that Start Before the Part”. I took it all the way up to 20 clicks and that did not solve it either.
You might want to verify on your system that these don’t fix the issue, but I’m not hopeful. I don’t know what else to try at this point.

OK, seems this is a long standing and well known issue. i went over to the NI forum. I don’t know how to set this but I found this:
“But thats not all correct you can enable “midi retrigger” where you set scene set by note and so on.
I personally can not rebuild anny of this issues with “midi retrigger” enabled.”
Here’s the post thread.

Looks like it was reported to NI.
I’m still reading but wanted to give you that at least.

@SF_Green Thanks for continuing to visit this post thread and trying to help!
I’ve already tried all those fixes and no luck.
I’ve sent an e-mail to mister Greg Ondo (Steinberg and Yamaha representative who is making 3-4 hours-long live hangouts on youtube).
As I am a new user and I am not allowed to post links on this forum, I will kindly ask our friend (SF_Green) to post a link in his next reply containing the answer of mister Greg Ondo.
Mister Ondo shows that the Steinberg Groove Agent vst is sync-ing perfectly with cubase , thus the problem must reside on the NI Maschine side.

The users that own both Cubase and Ableton Live say that the problem does not appear when running Maschine software in Ableton Live. They say it happens only in Cubase.

If none of the programmers of the two companies (Steinberg and Native Instruments) which build/check the code of the two software, do not see our problem, and the public representative of the two companies put the blame on the other side, the problem will never be solved - in those 2 posts that SF_Green has linked, the problem was first reported 7 years ago (in 2014).

  • Steinberg COMPLETELY ignores the “Support” section on their website;
  • The Native Instruments representative that has answered to my support ticket pretends that he does not understand what the problem is (he has seen the video - the same video that you can find above in this post thread), and he has told me: "if you want the Maschine software to repeat the previous bar of the track, you need to move the Cubase loop locators to encompass that section of the track " - he thought that I wanted to loop a previous section of the track… He pretends not to understand that the problem is that the Maschine software is not playing the first midi note which is encompassed in EVERY Cubase loop.

So, how do we get to the guys that are building the two software (Cubase and Maschine)? Who knows? Talking here on the forum does not help at all! It si clear that this is a bug and not a settings issue.
I shall add that the Maschine software, when running in Standalone mode, in its preferences - “MIDI” tab, has an option called “Clock Offset”
. Modifying that value could help - if that “MIDI” would still be there when Maschine is running as a VST…
The only reason i bought Maschine MK3 is to add midi notes on the fly in Cubase while Cubase is in Loop mode (by using the “Step” sequencer found on the Maschine MK3 hardware). If this is not working (the first note of the loop is not read by the Maschine software) I will send the Maschine MK3 back, ask for a refund, and I will buy the other option that i have (Roland TR-8S).
Hopefully the Roland TR-8S doesn’t have any sync-ing issues!?
But I need to know in time if this bug will be fixed, so I can return the unit in time.

Thanks!

Posting for @Marian
Greg Ondo addresses this question in Club Cubase May 21, 2021

Question is at 03:54:25. What causes Maschine to not retrigger notes during loop?

Here’s a little more data. First note I am using a Maschine Mk2, which behaves like your Mk 3.
Next, I just tried the same setup but instead of my Maschine, I used my Komplete Kontrol S88 Mk2 with the Maschine VST in Cubase just like before and it plays the way it should.
So it appears the issue is Maschine specific, and doesn’t exist in other NI hardware compatible with the Maschine VST, and the problem exists in both the Mk 2 and Mk 3 models.

But that makes no sense …
This should not happen!
To reproduce this problem I do not even need to connect the Maschine MK3 hardware - I only need to run the Maschine software as a VST in Cubase, and the problem is there. Why connecting the Komplete Knotrol S88 MK2 midi keyboard would change that and make the problem disappear? It makes no sense…
Are you sure about that? Did you tried multiple times?
Thanks!

Set it up from scratch twice with the same result. Maybe the keyboard series has a more advanced synchronization protocol or mechanism. It could be because it has the DAW mode driver that it talks to Cubase with. It has transport, track, and other features that don’t get locked out the way the Maschine controls do.
So swap your Maschine for a Komplete Kontrol keyboard and you’re all set! :grinning: