Cubase not recording Sustain pedal

Hello everyone,

I really need some help. After 6 hours of googling, I’m desperate.

Long story short: Cubase 5, Casio piano connected through USB-Midi, plug-in EZkeys Grand Piano, realtime playing works normally, pedal works normally, but Cubase will not record it. All notes are staccato.

In MIDI filter, there is only SysEx on both sides (default) and at Controller (down right corner) there is CC 123 allkeysoff. So all default.

Midi monitor shows the pedal activity as CC#64 with values 0 - 127. This should be normal, afaik.

So pretty much the pedal works, there is just some problem with Cubase/midi mapping or sth. that it is not recording the pedal.

I know there are many threads about similar problem, I saw them all…nothing works.

I will be really grateful for your help guys.

SOLVED!

The problem was in the way you add a track. You don’t go to Project/Add track …

but instead, you just press F11, pick your VST plug-in (in my case, it was EZKeys Grand piano), click Create and that’s it.
Now it records with the sustain pedal normally.

I tried your method, still doesn’t register the sustain effect when I play back the recording… I hope someone can sort this out…

Works as expected here, and without hassle since several years. And I don’t know in which way the OP actually solved the issue, but it’s NOT dependent of the VST Instrument (F11) window or in the way we are adding a track. So, few suggestions :

  • check if there isn’t any filter set in the Preferences>MIDI>MIDI filter page.
  • Be sure (just in case) that the Preferences>MIDI>Midi thru active setting is ticked.
  • Check also the incoming MIDI data (after a record) with the MIDI>List Editor : you should have several CC64 messages appearing in the recorded piece.

If there is still an issue, check the MIDI channel used in all the chain, from your keyboard/controller to the VSTi/instrumenrt that you have recorded. There is probably a mismatch, at this stage. Actually, I never had an issue, using my sustain pedal when needed.

HTWH…