Cubase playing video via CPU onboard graphics, not NVIDIA chip in laptop

I’ve never needed video when working on a laptop but am doing it now and am getting very bad playback - some clips just freeze after a few seconds. I’ve been working with video on desktops for a long time and have never had any issues.

In looking into the issue on my laptop I see that the onboard graphics on my laptop (Intel 630) is being used but the NVIDIA Quadro chip is not. Is there any way to force Cubase to use the NVIDIA chip? I don’t know if that would solve the problem but it’s worth a try if it can be done. I believe the NVIDIA chip does the decoding on the chip so it seems that might solve the problem.



On my laptop its a bios setting. NVDIA onboard or both.

The onboard intel graphics should be just fine.

It might be due to the video file itself. Is it mp4, variable frame rate, too high bit rate?

I have a laptop with that same video chip, I have found that no matter what config setting I try, the choice is always automatically made by the OS, and I also wonder if even makes a difference.

I convert any video I use in Cubendo to Apple ProRes. This plays nicely 100% of the time, large file size, less processing power needed to decode, less faffing, more work done.

I use XMedia Recode to do this, or you can use Audiospot ER Media